Jump to content
  • 0

3DConnexion Enterprise - VW Tools missing - SOLVED - NOT SOLVED



Somehow my Enterprise does not show VW's Tool Icons nor has the Options

in Driver Settings (Windows 10)


Did I do something wrong with my custom driver Installation where I

excluded all Options/Plugins of Software I don't have or need ?

I rechecked installation options but there was no VW option.


Is there any way to get the necessary files to manually install or do they

already reside somewhere in the VW App Folder ?

Edited by zoomer
Link to comment

6 answers to this question

Recommended Posts

  • 0
On 12/10/2018 at 4:57 PM, zoomer said:

I got it working fine for now, function wise.


If I remember correctly, the Solution to bring back the Commands, was :

In 3DConnexion's Programm Folder there was a Source XML Vectorworks

plus a Vectorworks 2018. So I duplicated the 2018.xml to 2019.xml and

edited content and names to point to VW 2019.exe.

I also deleted all VW settings content from User App Setting's (local or roaming ?)

3DConnexion's Folder.

In the user Folder I always had a "Vectorworks.xml" only, which content somehow

doesn't seem to be compatible with VW 2019.

Now I got a "Vectorworks 2019.xml" and my whole(Not just 12 or so !) Command List

re-appeared in Driver Settings.

And it doesn't disappear again from Driver Button Dropdown and Enterprise Display

after I try to assign a Command.



But the Icons are still missing.

(While I can see them for Bricscad initially in the Driver Settings AND on my Display)

When I try to find a clue if VW offers Icons on Enterprise's Display at all, in :




at around 2:20,

the Driver Dropdowns look exactly the same for me now.

So maybe there just aren't any Icons offered by VW,

so that there is no for me to spend the rest of my life searching for those ?

  • Like 1
Link to comment
  • 0

Hi Zoomer


Thanks for that, my problem is that I cannot find any .xml files in any of the 3d connexion folders and to be honest even if I did find them I'm not sure what I would then need to do to them to get them to work the way you have. But thank you very much for your reply


Having just paid out over $2000 for a version of VW that supposedly fixes all the bugs, I really don't see why I should have to delve into my system files to try to fix something that Vectorworks claims to work with its software and for me up until this afternoon did.

I guess this is just another Vectorworks typical case where they don't check that their software works properly with each new release. I now have a new version of Vectorworks that I can't use my 3d navigator with so I will now either have to go back to keyboard shortcuts and my mouse for 3d navigation or stay using VW 2017. The funny thing is I was about to give up on VW and try Archicad but I thought I would give 2019 a go because it was meant to fix all these sorts of things, stupid me.


Anyway sorry Zoomer I'm having a rant but thanks again for your help.

Link to comment
  • 0

OK I had my rant and a sulk and then I re read your posts very carefully and searched for Vectorworks.xml and found the files you said and edited a copy of 2018 to 2019 with the name and .exe changed to 2019 and it has worked so many thanks for your help. I don't know how you worked out to do that as a solution but I can now reprogram my Space Pilot.



  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...