Jump to content

Weird Spotlight Behavior

Recommended Posts

I am using VW Spotlight 11.0.1 on a Windows XP machine 850 mhz and 384M memory.

I was working on a file I had edited 8 months ago but did not create. When I opened it VW converted it from a v10.5 file to a v11 file. The first thing I noticed when I started renumbering lights is that the unit number would disappear on the plot. They seemed to have a label legend that existed in the folder but when I went to the LL manager there were none setup...So I imported my standard label legend and assigned the fixtures I had edited to the new label legend and that worked so everything seemed fine. In the meantime, I had created a new symbol which I had linked to the Light Info Record. At some point during updating info the lights I had drawn with the new symbol disappeared replaced by a generic box as if I was updating info and the symbol didn't exist. Sure enough, when I looked in the folder I had stashed it in, the symbol renamed itself. And not generic symbol 1 or something normal...It had named itself as if it were a lighting object...I mean 1057.0.1.1 or whatever object ID's are. I couldn't figure out why, it was just a rectangle, so I renamed the symbol, updated the fixture and everything seemed alright...Then I closed the program and went to bed. When I woke up and opened the file, the label legend had disappeared. The symbol had disappeared. And several classes had disappeared. The container folder disappeared. What remained was a strange unnamed folder in the resource pallet that when double clicked on prompted me to create a new resource. And when I tried to go thru the process of reimporting the label legend etc...It made me rename a bunch of records and classes that it said already existed in the drawing but clearly didn't. So when I went to change the names back from label-color2 to label-color it said there was already a something with that name which there wasn't. When I tried to make a new label legend it told me it couldn't because a folder existed called container and that I needed to delete it before I continued...Unfortuntely there is no folder anymore called that so...

Thanks for reading whoever has gotten this far. Help or suggestions would be appreciated...I know I could copy and paste layers into a new drawing but that could take hours and I rather not put in that sort of time to something that was seemingly done when I went to bed yesterday. Thanks.

Link to comment
  • 3 weeks later...

I've found this problem too....although it didn't happen until AFTER I did an export to Lightwright 4, made some changes, and imported the data information back to Spotlight.

To be sure, I went back a file version before I started exchanging information between Spotlight and Lightwright and this didn't happen. Once I did an exchange the problem was there again.

Link to comment
  • Vectorworks, Inc Employee

There is a known bug with import/export to Lightwright 4. It happens when an instrument only has regular accessories. Instruments without accessories or static accessories should work fine.

Is this the problem that you are seeing?

Link to comment


Does this known bug only affect accessories, or does it affect other instruments in a file that has accessories?

I've had problems when importing/exporting information to & from LW4 where the Spotlight ID's get mixed up and no longer correlate to the proper instruments. Which obviously makes transfering the information difficult.

Link to comment
  • Vectorworks, Inc Employee

It only affects the instruments with accessories, all of the othe instruments in the document will be OK. Nothing you do in LW should change the UID. If you work with the VW file after you export to LW then the UID might change and cause problems when you import.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...