Jump to content

More file loss and corruption

Recommended Posts

I've completely lost another file. That's twice since upgrading to architect. Lost a mornings work this time. Here are the details. Although this could be something local, I suspect there is still something not right with vectorworks as others have also reported problems with vw crashing. A colleague I'm working with has a new macbook pro that has also started having problems not being able to open vectorworks files and crashing vectorworks in the process.

12.5.1. Mac OS X 10.3.9. 512 mb ram.

While working I got an alert saying that the file had become corrupted and I needed to save it to a different location or the entire file would be lost. I tried saving to desktop. N.G. I tried exporting as older VW files. N.G. 3mb file became 0kb file.

This file started as a file created by someone else. I worked on a duplicate. It needed to be adapted for a new variation on the original project. it had a lot of classes---probably because at some point an autocad file was directly imported. I reduced the classes to dimension and none. then created a class "Acad" to hold imported data. I noticed some odd behavior when cleaning stuff out of the file. Objects which would display, but which could not be selected. There were some objects which I could only delete by deleting the class or layer. Maybe there was something wrong with this file at the start. Would have been good to know.

Then I imported some autocad data into a new file. Then I deleted the classes and dumped the data into none. Then I created an Acad class and assigned that to all the objects. Then I copied one of the floor plans and pasted it into the VW file I was working on, as a group. Then I ungrouped it and deselected the objects. At this point they could not be reselected. That didn't seem right so I undid back prior to the paste. Tried it again. Similar results, then the message that file was hosed.

Permissions check out fine. Disk utility reports volume appears to be ok.

No problems or strange behavior with any other applications or files.

Was not using an autosave back up file. Was not autosaving without an ok. No workgroup references. No server. Local machine only.



Link to comment

If you have autosave set to save to a backup folder, then that may be causing the problem. Turn the backup folder off for now, or work on the file off the network.

Next week, a new updater will be available next week and it will address this problem.

Link to comment

For what it's worth --

While I'm certainly no expert at VW, my experience has been that mystery problems are sometimes solved by reinstalling the MacOS, and perhaps VW as well. In addition, 512 MB memory may not be enough; it may seem to be enough, but the MacOS has always been a memory hog and I've noticed that with even slight file corruption, VW will crash on my G4. When I was running on this G4 Pbk with 1.5 MB and no other apps open, the activity monitor would show alot of ins and outs to the hard drive, which to me indicated it wasn't using ram efficiently.

Anyway - good luck!


12.5.1 on an Intel iMac

Link to comment


I've had this problem of file data loss with two different files, in the last 3 weeks. The first file had workgroup references and viewports, the second did not. I'm not having problems with all files. I made a second copy of the original file and have been working on the second copy without further problems. It seems the problems followed the class deletion work I was doing. There were a jillion classes in the autocad file so I was deleted many many classes with one delete action.

So either things are random, or something I did stressed the file out.

Only thing I can say for sure, based on my experience and readings here, is that some files are getting corrupted. Haven't seen problems of that kind in a very long time. Haven't had any problems since the last mac 12.5.1 updater.



Link to comment

Good day, I too have been having files corrupted. In my case the files are from different jobs, different sizes. One thing I noticed in the "known issues" was that VW12.5 has a problem reading and writing to folders that have more than 31 characters. I changed my folder names. No help. I was autosaving to a backup and forgot to manually save when the autosaves occured (belt and suspenders approach) VW corrupted the backup file and left me with the drawing I had started with 3 hours earlier. Colleague suggested that the problem was 12.5.1 so I deleted VW 12.5.1 and re-installed 12.5.0. So far, no problems.

However, I know realize I deleted my precious Offset Duplicate command which I have been coveting since Nemetschek dispensed with this indispensible tool. If anyone remembers it, it was similar to the Autocad Copy command. Select an object, pick a start point , pick and end point and voila, a new copy appears at the end point. What could be simpler. Where is the equivalent in VW 12. I can't find it and it's driving me crazy, its' driving me nuts!

Link to comment
  • 2 weeks later...

There's an old joke about three golfers. On the 11th hole one of them, Fred, had a heart attack and died. For eight holes it was, hit the ball and drag Fred.


It happens again this morning. A dialogue, "The file has been corrupted on disk..." As in reduced from 10mb to 0kb. Same conditions, equip. etc. as my first post.

In fact it seems impossible to save to the hard drive I'm using when prompted by the dialogue. So I've learned a couple things.

1. Start the day with a duplicate of the file.

2. Keep an external drive near by to save (pun intended) the file.

This time I didn't lose anything. File is back where it was. Saving fine again.




Link to comment

Yep, me too. 20 mb file reduced to 0, unable to save, same as above. Unfortunately didn't have the safety mirror running. Lost the lot.

For your infomation Katie...

VW 12.5.1(65397)

Mac Pro Quad 3 ghz, 3gb

VW, Safari, Mail, Preview running

Wasn't autosaving to a backup file, wasn't autosaving without OK,no workgroup references, no server, small network (Main Mac and mini)

VW itself didn't crash, just refused to save and ate the source file.

Funny thing is that before 12.5.1 VW was being unusually crashless; now crashes seem to be really quite frequent - had one today whilst using the create polygon from inner boundary tool, something I hadn't had since VW 10. Certainly haven't lost ENTIRE FILES before, ever. Like Donald and Don (see above) I've been knocking around on macs since the Plus. Don't know what you've changed with 12.5.1, but it's a disaster; at least give us a link to set us back to 12.5.0 so we can at least get on.



Link to comment

I've been seeing similar corruption happen with my neighbor's setup, but not with mine. He's using a G4 powerbook with 512mb RAM, and I'm using a G5 iMac with 2.5 gigs RAM; that's one difference. Another is that as a landscape architect, he routinely inserts large amounts of DXF- or DWG-imported data into his drawings; often very large ACAD drawings, such as extended topographic surveys. I've been working with him on one project doing a small building to be inserted into his landscape designs, and all the files I gave him became corrupted after he touched them. It turns out that he copied-and-pasted objects from his larger design drawings into mine, somewhere along the process. I believe that those larger drawings of his included topo surveys originally prepared in ACAD.

My suspicion is that there's an odd, but specific combination of things that come together to corrupt a VW file: the insertion of large amounts of DXF/DWG data, as I've indicated, along with a very small amount of memory. Also there's something odd going on with his in-office network that I suspect may be playing a role, perhaps the backup issue mentioned earlier in this thread (he hasn't upgraded to 12.5.1 yet).

I've been playing with 12.5.1 and its predecessors for a while now, both on the office iMac, and on a Macbook at home (with 2gigs RAM) and haven't experienced the kinds of file corruption I've observed with my neighbor, so my theory is that the items I've mentioned above are directly responsible.

Dan Jansenson

Link to comment

My big toe says something about MacOS, memory, autocad and classes. Note, however, that Charlie is running 3 gigs of RAM. Also one of my problem files had no autocad history. The crashes I've had are usually preceded by disk activity (sound). The file corruption is sudden and without warning. It seems like there is a rogue background process, one that needs to learn to heel.

I'd say there is a statistically significant sample now.



Link to comment

Today's experiences...

ok - after losing a couple of files yesterday (see above), duplicated all my files on the active project first thing and moved them across the network to the mini (all done from finder, not VW and save as). Had a prospective client later on so the thing had to run. Opened a main file (500 mb) and set up an animation, left it to run. Back later, everything ok but within 5 minutes of sitting down the familiar messages returned. But this time I had the backups so the head was a little clearer; tried to save to local disk, no go (no surprise). Tried to save across the network under a different filename - success! I was then able to save to local disk under the original filename no problem.

But why?

No autocaddery (at all; in fact to "foriegn" program input at all), a few classes - 20 odd, not vast. Saving was to desktop of logged in admin user. I had activity monitor running at the time showing cpu in the floating window and had one core run full bore for a couple of seconds before curtains; sorry can't remember wiich one - rather backs up Donald's rogue process idea though.

I don't think it's file size. I've had a file expire containing a couple of circles only as well as big buggers. I'm experimenting with autosave off, doing it manually instead. I'll let you know. Personally I think it's something to do with the file naming or path hierarchy; a misplacing between VW and OSX as to what should be where. When the autosave timer comes around there must be a checking process as to the state of the field and I think this is what is misfiring. When my kit implodes I don't always get a save dialgog come up, Mostly it justs "file is corrupted" at me and swearing ensues.

The fact that a filename is showing zero K when seconds before it was showing several meg indicates that it's the data that's lost it's connection to it's name rather than the data evaporating.

I seem to have become overly verbose for which I apologise profusely.



Link to comment

Good evening Katie,

I'll send it all off of course, although it'll be tomorrow now (22.40 currently in the UK).

As to the path name it'll be -

/users/charles/desktop/slew ring.mcd

for the recently deceased drawing. Other different file names with a similar path have also expired as well as some saved direct to drive, i.e. /filename

I've always used local disk for saving until this problem arose since which I've been using a networked mini as a backup (as outlined above). I've only had problems with the local hard drive but then I've only saved across the network as an escape route after I've been bitten. Donald sounds as though he has more experience of this problem than I have so it may be worth a cross check.



Link to comment

I just experienced the file loss/corruption problem yesterday. Was able to follow the instructions to save to another location (flash drive and external drive). Both of these saves were OK, but the local file was only 48K. I saved as other versions to the local drive with 0 kb results both times.

I called Applecare immediately before checking this forum first. They advised me to take my iMac G5 into an Apple store for diagnosis. All the hardware, memory etc checked out. They said it must be the software.

I asked about file naming, number of characters and path hierachy as a possible culprit. They ruled these out as possibilities from the OS point of view.

My file was 25.4MB and did not include any dxf/dwg imports. I had imported some SketchUp files, but had removed them before file corrupted.

I had also turned on all the classes to find something and undid that to return to the original setup. Sometimes I think that this process is very difficult to compute and everthing gets boggled.

I certainly hope this problem can be resolved quickly. My confidence is at a new low. As it has been ever since I installed 12.5.

This problem has caused me to save my files in more than one place to avoid redoing them. confused.gif

Link to comment

Katie & Others,

I too have been having this problem since upgrading to 12.50 (I thought 12.51 would help, but it didn't). My personal work around as been to work off my local hard drive, not off the network. I have ONLY gotten corrupted files when working off the network. I used to think our IT department was running some intrusive scanning software which would interfere w/ the way VW performs, but seeing this is also a problem with my Mac brethren,I now don't think this is the case.

Please keep us informed on the the status of this. I work with 16 - 20 users who have not upgraded past 12.0 because of this problem. Until we know this is figured out, we won't upgrade.

Katie, I will also send you a seperate e-mail w/ the specifics at tech@nemetschek.net.


Matt Dirksen

Link to comment

Today I noticed a corruption problem with the export to pdf (quartz only) command. If I export a pdf, say I call it 2.pdf, and it works fine. But if I export another with the same name, it asks if I want to replace the one that already exists with that name. I say yes.

Now it is a 0k (pdf) file. I've done this a couple times.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...