Jump to content

Vision crash when importing MVR file

Recommended Posts

Hi all


I am having a problem, importing a element of my set design into Vision. 


It contains multiple symbols, some textures and meshes. 

The model is imported into Vectorworks from Google sketch up. 


Every time I try to import, Vision crashes. 

Do any of you have an ide about what is happening here? 

Don't vision like to import object symbols, containing other symbols? 


I am out of ideas 🙂 

Dollys for support.vwx

Link to comment
  • Vectorworks, Inc Employee

Hey! Vision should have no problems with symbols or nested symbols. But, you are still having issues and so there are a few things we might be able to do to "work around" this while we investigate things internally to try to reproduce this crash and hopefully find a fix.


For starters, there are two main ways to get a file from VW to Vision. The first involves the Send to Vision commands which automates a lot of the work for you. It is possible that this is causing issues. So, I would recommend that while we work through this issue you stick with the second method. This method involves using the Export menu commands directly, which will save the file somewhere on disk such as the Desktop. Once the file is exported, you can then Open it with Vision or Merge it if you'd like to pull it into an existing Vision document. I'd recommend sticking with the Open command in Vision rather than Merge until we figure out what is going on with the crashing.


The next thing I'd like to discuss are the two main file formats we use for sending data from Vectorworks to Vision and the variations of those file formats.


By default, and our general recommendation, the MVR file format will be used. The MVR file format has 2 variants. The one we use by default and again recommend is the glTF-backed MVR. If you are having issues with this variant of MVR, I would suggest trying the older but more stable variant which leverages 3DS. To export a 3DS-backed MVR, you simply need to click the checkbox for 3DS during the MVR export.


If you are having issues with both glTF and 3DS backed MVRs, there is one other file format we can try in order to get you on the ground running. This file format is very old and limited in its feature set. But, it is the first and original file format used to transfer data from VW to Vision. That is ESC. There are not really any options for ESC exports. It just sort of happens 😛 And ESC was created before GDTF. So, it will not work with those types of fixtures if you are using them. That being said, ESC takes a radically different path through the code base in both VW and Vision and so we might "luck out" by getting your file to import this way.


Hopefully that all makes sense! We'll take a look at the file you've posted in-house and see if we can reproduce any issues. From there, we'll investigate things and try to report back our findings! Thank you for your patience and hopefully one of the above suggestions works for you.

Link to comment
  • Vectorworks, Inc Employee

So, this is such a silly issue. But, the problem is actually that one of the texture resources in your VWX starts with a `*`. Particularly, `*7`. We obviously need to fix Vision so it doesn't crash in this scenario and still works as you'd expect. But, for now, I would suggest avoiding starting any texture resource in VW with a `*`.


I apologize for this issue and tried to respond as soon as I had time to investigate. I hope this helps!

Link to comment
  • 2 weeks later...

Hi @bbudzon

Thanks for your responce, and sorry for my long responce time. 

I ended up drawing it again in Vectorworks, instead of using the Sketch up import I got from my set designer. 


However I am very happy that you looked into it! 

Thanks a lot! 


I always transfer my file from Vectorworks to vision via MVR. 

Primary because of the better quality. 


Best from Mathias 

  • Like 1
Link to comment
  • Vectorworks, Inc Employee

Yup! Looked into it, found the problem pretty quickly, and the solution seemed fairly straight forward 😄 The fix tested well on my machine and our internal QA department verified the resolution. This problem should be fixed in Vision 2023. 😉 

Link to comment
  • 3 months later...

Sorry to report that I am having the same issue, Vision crashes instantly upon import or merge.

I have tried both MVR and ESC and also just exporting a few fixtures and no geometry.

Tried on a m1 and an intel laptop.


v2023 with everything up to date. 


How can I proceed to address this?


Thank you

Link to comment
  • Vectorworks, Inc Employee

It is hard to say from your post if this is the same issue or a new one. The fix mentioned in this thread only ensured that we do not crash if the name of a texture in a VWX starts `*`. Perhaps, you could post your VWX for us to test with internally and try to reproduce?

  • Like 1
Link to comment
  • Vectorworks, Inc Employee
20 hours ago, fuberator said:

v2023 with everything up to date. 

Can you confirm which SP of 2023 you are running? If you could post a screenshot of the About Vision dialog, that would be helpful too as it includes the build number. Thanks!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...