Jump to content

LarryO

Member
  • Posts

    353
  • Joined

  • Last visited

Everything posted by LarryO

  1. As I write this the 'Grid - Rectangular' tool is attempting to calculate how many horizontal grids it can place in a height of 16256mm with zero Y Spacing. I didn't want any horizontal lines so I accidentally inserted zero into the spacing field. ATM VWs has achieved the utilization 140MB to complete its endeavor and refuses to give up. There doesn't appear to be a means to cancel operations anymore, at least not on the Windows platform. Forced +?-*~CRASH°-*~? to desktop appears to be the only way out. All because I wanted 4 circular grid bubbles at my annotation line ends. 😂
  2. Are there any optimized profiles for the NVIDIA Quadro P2000 that we should be using for VW2021? Can these settings cause flickering? In the past 8 weeks or so I've noticed that the primary screen that I run VW on has been unpredictably flashing the VW application content, the secondary screen with identical hardware doesn't usually flash, but the whole system did go down during one of these events. I also get unusual response from clicking in the object info palette. Kind of like a delay until moving the mouse. This has also caused the program to crash if I try to move on too quickly to another click event. Is there a possibility of the Razer mouse driver and VW being in conflict, or the video card hardware about to die?
  3. Stretching my mind a bit here, but I recall that there were a aspects that Autocad's document exchange format DXF did not track but of course their dwg format did. I would start with trying to export to DWG version 12. (I've not checked if that version is still there in the export settings) VW10 can import DWG files.
  4. The palette of Classic Vectorworks Colors appears unedited, as carried forward from the Minicad days. However the palette of colors named Standard Vectorworks Colors does not match the VW2013 version of the same name.
  5. I've been using a circle to generate railings. I find that wherever the path changes abrupt direction like an intersection node of a polyline, as opposed to a radial corner, I can snap to the quadrants. But the point generated for the tool seems to be projected onto the active drawing plane if in plan view. There are definitely some areas where the developers need to work on. When in an ISO view you can snap the first end of a line to the quadrant point at an end or change in direction but the closing end point will not snap to the opposite quadrant in the junction. (To find the centre of the profile's intersection for instance.) And snapping from the end point of a 3d line to another 3d line end point is also a lot of trouble. Especially if the closing end point is located where another object's point is, like the quadrant of the circle extrusion. The line is often created on the active x/y plane at zero z but for seemingly unpredictable reasons will occur at z elevations other than zero. I do a lot of decomposing and recomposing of nurbs pathing to get the tubing (circle profile more often than flattened ring) flowing continuously in the correct locations for 3d railings.
  6. I find that switching to Wireframe allows snapping to intersections, quadrants, end points and the surface but I've not found much use for the latter.
  7. Thanks Matt. I so miss the days when companies produced encyclopedic manuals with extensive indexes for their software. My searches are frustratingly unsuccessful. I never seem to know what word or labels have been assigned to what I am seeking. Indexes were such an amazing resource for finding new and forgotten things.
  8. What setting causes the little cubes to display beside the design layers? I seems to be file specific. They don't show in our Imperial temple but do in the Metric one.
  9. 1. Try to get the note text under the leader line. Only happens when directly aligned with the dimension line. 2. Try to select the dimension by selecting the note text; you cannot! This is related to a previous bug report sent in shortly after notes were introduced which was confirmed but may not have been elevated to bug status. My previous report noted that one cannot select note text after decomposing a dimension string except via the bounding box method.
  10. There is also the small chance that the VW9 bolt script works in your current version. Small because a lot of Vectorscript functions have been deprecated and renamed after being rewritten since that version.
  11. Thank you. Previous draftsman set line weight scale to 2 in normal viewports.
  12. I'm at a bit of a loss as to why these 3 viewports are displaying different line weights for the same object. The lower right is a section view port and seems to be displaying correct line weights. Top left normal VP, all lines except break line is 0.25mm. Two vertical lines that appear correct in top VP are in the annotation space. Bottom right normal VP, break line and blue lines are in annotation space and appear correct thickness.
  13. 1cm : 1M [1000mm] 1cm : 100cm 90cm = 900mm (=35.43") 2.54cm = 1" 8'-4" = 100" Eliminate the eccentric imperial systems of quarters, rods, inches, chains, yards, furlongs, eighths and smelly feet and it is easy to visualize.
  14. Thanks Pat, I done the deeper dive into the polyline definition a few times thinking that what you said here might be the case. I actually redrew the outline in this one because in the first rendition I started with rectangles and used add surface followed by the fillet tool. Which I have seen create a node at the start or end of the radius node. In the second attempt I started with only corner points and then edited the polyline changing the desired one to radial nodes. That at least ensured that there were no extra nodes introduced when I re-rendered the viewports using Hidden Line and Dashed Hidden Line. At which point I had become frustrated and posted here. After Jim's post got me thinking again, I rotated the object so that one of the sides would be seen in top/plan view. The view rendered correctly. So I reverted and the bad condition returned. So on a hunch I raised the object 10mm above the xy plane upon which I had created the outline for the extrude definition. To my surprise the viewports rendered correctly. One precondition seems to be that a solids Add or Subtract operation has to have been performed upon the extrude (or steel shape). The Subtract solid being utilized with this 3D bent plate to create the holes.
  15. In this instance the plan view is drawing correctly. Having to draw/redraw elevations in 2d kind of defeats the benefits of purchasing a 3d drawing application. Interestingly though, by moving the 3d object 10mm or rotating it so that the extrusion's external start plane and its polyline definition plane/origin are not in the same location has made a difference. At least for this object. And if this origin and plane alignment is the trigger it could be why I am seeing this so often. I have a habit of maintaining this alignment where possible so editing is not always a search for where is the defining object.
  16. I've been using a workaround to address this issue for some time now but the workaround has become less and less reliable. In the past 5° was a sufficient smoothing angle, but sometimes even 18° is not sufficient to prevent radial lines from appearing at the edge of a flat surface. What is it that we need to do to eliminate these radial lines from appearing in basic 3D objects? Drawings in which these lines appear continue to cause confusion and errors on the manufacturing side of our business. VW2021 SP4 (Build 602791) (64-Bit), Win 10 Pro version 21H1 Build 19043.1110, Xeon 2123 16GB RAM, NVIDIA Quadro P2000 5GB
  17. Out of curiosity only. If the condition cannot be evaluated does the parser capture for processing either the true or false value?; or throw an error dialog or a null value? The way it is written reminds me of a process without error checking. If read left to right it would capture the false value into the register then process the condition where by a true result would overwrite the register value with the next value to the left. (APL processed code lines left to right) Where as Pascal or Basic+ type of formatting will have the condition for evaluation first resulting in selectively choosing to ignore either the first value or the second value and do a single write to the register. Hmmm. Overly simplified of course. hehe
  18. Start first by asking yourself if the effort is worth in time and or money savings to pay yourself to learn Pascal, Python or C++ or to hire someone to script for you. If yes, identify / document what type of interaction you hope for when first creating the object, the basics of how and what you expect when editing a point. Select the best predefined plugin object to suit the profile you just documented. Then just start coding. You can start by mimicking the steps you would you would do if you were manually creating the object. Adding in the variables to store values and locations as you go. Take a look at some other coding work to get a feel for some conformity in the writing structure of your code so it remains easy to follow afterwards. Invariably you will want to tweak and correct the functionality of how you interact with your object and other aspects. Inquire in the Vectorscript area if you are willing to take the plunge in learning scripting. Good luck and don't be afraid to share your mistakes.
  19. Arrgh, Thanks Matt for find that. It was a bad day VWs crashed to desktop three times that day while working in that file.
  20. I was able to reduce the file size while retaining the rendering error for anyone capable of hunting down this bug causing these dimensional errors. File attached. (edit: error is still present in today's SP4 602791 update) VP RENDERING INCORRECT OBJECT SIZE.vwx My bad, I forgot these needed to posted here in trouble shooting. Please delete the double posting over in general if not applicable. Thanks.
  21. The size of the HSS in section B-B is as labeled using the 3d square tubing. 1. BUT when rendered in the section viewport it is only 74mm as evidenced by the sectioned tubing being slightly larger when they are all the same size. I had to fake the vertical dimensions. 2. Also the solid line parallel to the bottom edge should not be there. The smoothing angle is set to 5°. These lines appear unpredictably in part or whole from radial point(s) along an extrusion when said solids have been operated upon by one of the 3d modelling tools (add, subtract, section, etc.). VW Mod8402 Custom's House - roof hatch frames in ventilation shaft.pdfel file is 12.8MB8402 Custom's House - roof hatch frames in ventilation shaft.pdf 855.12 kB · 8 downloads
  22. My bad, I forgot that these need to be posted to the trouble shooting forum. (edit: please move this posting to Trouble Shooting if applicable, Thanks.)
  23. Has the forum ( and Nemetschek/Vectorworks) simply stopped elevating problems to the known issues part of the forum? If we don't acknowledge it, it doesn't exist premise! (Just like politics.) Nothing new was elevated throughout all of 2020. (unless the site's sort feature is broken) In working more with 3d elements and viewports in VW2019 and VW2021 I have had more crashes to desktop (CTD) this year than the past 5 years. Somewhat reminiscent of the MiniCad 4 days. Now this could partially be due to switching to the Windows platform and its frustrating implementation of palettes which prevent the keyboard shortcuts from being activated unless escape is pressed first. But I find with my mouse (Razer if that's a factor) that selecting buttons in the info palette, the layer button in the titlebar and a few others are causing crashes to desktop. Today it seemed like a keyboard shortcut triggered CTD. In addition, the inability to select the note text of an exploded dimension remains as a bug. Rendering viewports are having multiple issues with lines that should and shouldn't be displaying. This week I had an object in a section viewport that was drawn incorrect and therefore dimensioned incorrectly. Fixed, not a bug.
  24. This would depend upon how you have implemented your titleblocks. I our company's instance we have a symbol with editable fields installed by our plugin. We simply edit that symbol and the new logo will appear relative to the symbol's origin. Our pages have different borders depending upon size of page but the actual titleblock size and its orientation remains the same. This fixed symbol size helps when working with other applications such as Bluebeam that look for page numbers and other identifying features based upon location in the document set relative to the page corner or origin.
  25. I was able to reduce the file size while retaining the rendering error for anyone capable of hunting down this bug causing these dimensional errors. File attached. (edit: error is still present in today's SP4 602791 update) VP RENDERING INCORRECT OBJECT SIZE.vwx
×
×
  • Create New...