Jump to content
P Retondo

.dwg conversion in VW2020 not working correctly

Recommended Posts

Anyone else experiencing this problem?  When I export a file, with multiple layers visible, to .dwg and select "Export as dwg layers: layers," the resulting .dwg has only one layer with all objects crammed into it. 

Share this post


Link to post

I don't understand the nature of your issue.  It sounds like you are exporting vectorworks design layers to AutoCAD Layers.  AutoCAD "layers" = Vectorworks "classes"  perhaps this is your issue?

Share this post


Link to post
Posted (edited)

@P Retondo You're telling Vectorworks to export Vwx Design Layers as AutoCAD Layers.

You need to switch it to Classes.

2042101837_ScreenShot2021-03-31at2_58_50PM.thumb.png.6fc5506fcbbf4033c7dbf089e415e0f1.png

Edited by jeff prince

Share this post


Link to post
Just now, jeff prince said:

@P Retondo You're telling Vectorworks to export Vwx Design Layers as AutoCAD Layers.

You need to switch it to Classes.

Jeff, I don't want to export classes as separate layers in .dwg, I want to export layers as separate layers in .dwg.  Used to work in the past, but now it doesn't seem to.

Share this post


Link to post

@P Retondo If I take a vectorworks file with multiple design layers and export it to DWG using Vectorworks layers to AutoCAD layers, the result is each design layer in vectorworks is translated into individual AutoCAD layers with all Vectorworks class information stripped.  That's how it has worked for as long as I remember.

 

What are you trying to achieve?

 

Share this post


Link to post
Posted (edited)

Jeff, thanks.  I have layers with different stories of a building in separate layers.  I want the same layer structure in the exported .dwg, exactly as you describe.  I was wondering if anyone else has noticed that this doesn't work any more.

 

The way I know this is that my structural consultant complained that everything was in the same ACAD layer.  I imported my .dwg back into VW, and everything came in as one layer - I don't maintain a license of ACAD anymore, but I trust that what the engineer told me is true.  I had to export separate files for each story.

Edited by P Retondo

Share this post


Link to post

@P Retondo You do realized that AutoCAD does not have the capability to receive both Vectorworks Class and Layer information in the same file right?

When I send .dwg to architects, I export each design layer as a separate file and activate the Class/Layer Conversions as indicated the image I posted earlier.  The AutoCAD recipient then receives separate files for each design layer with Classes preserved.  The recipient can then xref in the separate files as they need for their purposes.  AutoCAD doesn't have Design Layers, so most folks use xrefs to simulate the behavior we enjoy in VWX.

Share this post


Link to post

@jeff prince Jeff, thanks for your input.  I worked with ACAD for 4 years, so I am well aware of the layer/class issue.  My purpose in bringing this up here is to find out if this might be a bug so I could report it.

Share this post


Link to post

@P Retondo No problem.  The behavior you are describing is not a bug, it's actually a useful feature.  I have plenty of AutoCAD clients that like my design layers to come into their system as a single autocad layer.  They prefer the simplicity of it, though it wouldn't be my personal preference.  I'm struggling to understand what it is that you think is actually a bug here.

Share this post


Link to post
Posted (edited)

@jeff prince When you select "Export DWG layers as : layers", your layers should become separate layers in ACAD.  That's the way it has worked in the past, and since it isn't working that way now, that would be a bug - correct?  The behavior in v2020 is not consistent with behavior in previous versions, or at least that's what I'm trying to confirm with other users.  Having all your layers come into ACAD jumbled into one layer is distinctly unhelpful to most of my collaborators.

Edited by P Retondo

Share this post


Link to post
1 hour ago, P Retondo said:

@jeff prince When you select "Export DWG layers as : layers", your layers should become separate layers in ACAD.  That's the way it has worked in the past, and since it isn't working that way now, that would be a bug - correct?  The behavior in v2020 is not consistent with behavior in previous versions, or at least that's what I'm trying to confirm with other users.  Having all your layers come into ACAD jumbled into one layer is distinctly unhelpful to most of my collaborators.

 

All I can say is that I'm on 2020 and it works correctly.

When I export DWG layers as layers, each Vectorworks design layer appears in AutoCAD as a unique AutoCAD Layer.  That's the desired behavior.  Maybe you are doing something wrong.  And no, I'm not a NNA engineer 🙂

good luck to you.

Share this post


Link to post

Thanks, Jeff.  I wonder if it has something to do with which version of ACAD I'm exporting to.  I'll check that out.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...