Jump to content
Taproot

2019 Titleblocks - Troubleshooting

Recommended Posts

We're just starting to transition our template file to 2019 and have discovered that for some reason the software has duplicated all of our titleblocks.  I discovered it when experimenting with the "Create Sheet List" command.  In the attached screenshot, I've deleted the duplicate for the first sheet, but you can see all of the other sheets are copied.  It looks like the solution is to manually go through each sheet and draw a marquee around the titleblocks and manually delete one. 

 

FYI: We ran into this issue last year as well, but just accepted it as a nuisance. 

Screen Shot 2018-09-17 at 9.58.54 AM.png

Screen Shot 2018-09-17 at 9.59.35 AM.png

 

 

 

Edited by Taproot

Share this post


Link to post

OK, file sent via Private Message.

 

Is there a detailed guide to titleblocks for the current version?

I've gone deeper and I can't quite make sense of how it is supposed to work.

 

Our Titleblock predates the Manager, so I'm used to thinking about it as a symbol with fields that attach to records.

The records are then reported to a schedule / worksheet.

 

Now, it seems like the Manager has added some additional layers to that process and it's not very clear how to work with them.

For Example:

 

In our titleblock , we have an "In Project" field with a Yes/No list of options.  When it = "Yes" the sheet is included in the Drawing Index, when "No" it is ignored (but still present and can be added to the set at a later date).  In 2019, this field doesn't seem to function.

 

Here's a screenshot of the Titleblock manager.  When managing the sheet data, some of the fields are in italics and some are not.  I assume italics designates my custom fields and standard text are system supplied fields. Is that true?

 

I've had erratic results.  Sometimes the italicized fields will show up in the manager (as they do in this screenshot).  At other times they will not.

 

 

666435930_ScreenShot2018-09-17at1_10_34PM.thumb.png.0a0d6cbc095ac62b8538f083514915a2.png

Screen Shot 2018-09-17 at 1.10.34 PM.png

 

Continuing on:  I've placed the new titleblock "Issue Index / History" worksheet in my file.

Editing the Criteria to filter display results no longer seems to work.  If I limit the criteria to my 'Taproot Titleblock' records, zero results are found.

So, the actual criteria is either controlled somewhere else, or my data is being captured by the manager and filtered so that not all of it comes through.

 

I'm a little stumped ... guidance would be appreciated.

 

23211337_ScreenShot2018-09-17at1_15_20PM.thumb.png.32d5f2560897b78070170df85c983561.png

Screen Shot 2018-09-17 at 12.49.47 PM.png

 

I don't know why the images disappeared.  I've attached them again.

 

 

Edited by Taproot
Images disappeared

Share this post


Link to post

@Taproot

11 hours ago, Taproot said:

Is there a detailed guide to titleblocks for the current version? 

 - Check out the help site of vectorworks and search for Title Block Border there. Also, you could check out this demo -

 

11 hours ago, Taproot said:

In our titleblock , we have an "In Project" field with a Yes/No list of options.  When it = "Yes" the sheet is included in the Drawing Index, when "No" it is ignored (but still present and can be added to the set at a later date).  In 2019, this field doesn't seem to function.

 - You could accomplish this by selecting only the TBBs from "Select Sheets to Use" dialog in Title Block Manager, that you would like to be included in the worksheet report and after that create the report.

 

11 hours ago, Taproot said:

Here's a screenshot of the Titleblock manager.  When managing the sheet data, some of the fields are in italics and some are not.  I assume italics designates my custom fields and standard text are system supplied fields. Is that true?

 - Yes.

 

11 hours ago, Taproot said:

I've had erratic results.  Sometimes the italicized fields will show up in the manager (as they do in this screenshot).  At other times they will not.

 - I assume that you have changed the selection from "Select Sheets to Use" dialog? In the Title Block Manager, if there are multiple TBBs selected, we display only the common Project/Sheet Data fields that they have. You could view all of the Project/Data fields of a single TBB, by switching to single edit mode from the buttons in Top Right of Title Block Manager dialog.

Another reason for this might be that you have selected external files that are not loaded. For files that are not loaded, we display only the fields we know they have for sure - the default fields. If you want to see what fields are there actually, you will have to load these files from Select Sheets to Use dialog and Load Files button.

 

12 hours ago, Taproot said:

Continuing on:  I've placed the new titleblock "Issue Index / History" worksheet in my file.

- The Title Block Border is not using the record that you have previously used. You should change your criteria to match the new records used by the Title Block Border - Title Block Project Data and Title Block Sheet Data.

 

The attached images are not opening, that is why I am only assuming what might be the problems.

 

If you have any other questions, feel free to ask them here.

 

Best Regards,

Nikolay Zhelyazkov

  • Like 1

Share this post


Link to post
7 hours ago, Nikolay Zhelyazkov said:

@Taproot

 

 - You could accomplish this by selecting only the TBBs from "Select Sheets to Use" dialog in Title Block Manager, that you would like to be included in the worksheet report and after that create the report. 

 

I did try this, but I found that I had to add each sheet one by one. Shift or Command clicking wouldn't work for multiple select.  So this option seemed a little tedious.  Perhaps you could check if that is normal behavior or just my experience.

 

 

7 hours ago, Nikolay Zhelyazkov said:

 - Yes.

 

 - I assume that you have changed the selection from "Select Sheets to Use" dialog? In the Title Block Manager, if there are multiple TBBs selected, we display only the common Project/Sheet Data fields that they have. You could view all of the Project/Data fields of a single TBB, by switching to single edit mode from the buttons in Top Right of Title Block Manager dialog.

Another reason for this might be that you have selected external files that are not loaded. For files that are not loaded, we display only the fields we know they have for sure - the default fields. If you want to see what fields are there actually, you will have to load these files from Select Sheets to Use dialog and Load Files button.

 

OK, I'll dive into this deeper.

 

 

7 hours ago, Nikolay Zhelyazkov said:

- The Title Block Border is not using the record that you have previously used. You should change your criteria to match the new records used by the Title Block Border - Title Block Project Data and Title Block Sheet Data.

 

It sounds like I just need to rebuild my titleblock with the new standard fields.

Speaking of which - what are they? 

Is there a list somewhere or should I just use Pat's script to determine the field names for criteria, reporting, etc.?

 

 

7 hours ago, Nikolay Zhelyazkov said:

The attached images are not opening, that is why I am only assuming what might be the problems.

 

 

 

I'm not sure what happened to them.  They worked initially.  I've uploaded them again.

 

Thanks for your help.

Share this post


Link to post
18 hours ago, Taproot said:

I did try this, but I found that I had to add each sheet one by one. Shift or Command clicking wouldn't work for multiple select.  So this option seemed a little tedious.  Perhaps you could check if that is normal behavior or just my experience.

- I can not reproduce this. Check out the attached recording showing how shift click and command click are working for me.

 

18 hours ago, Taproot said:

It sounds like I just need to rebuild my titleblock with the new standard fields.

Speaking of which - what are they? 

Is there a list somewhere or should I just use Pat's script to determine the field names for criteria, reporting, etc.? 

- You could see all the fields of the TBB from Manage Project/Sheet Data dialogs. The default fields are the ones that are not italic.

As for your criteria, try using boolean field. It is working with boolean field for me.

 

Share this post


Link to post

I ran into the same problem, and my workaround is changing the custom boolean field "In Project" to the standard boolean "This Title Block Is Active". This field has a checkbox on OIP,  so it's a little bit more convenient than going through "manage sheet data" to get to the custom fields. I don't use issue manager, so this approach is ok.  Vectorworks should fix this problem though. What's the point of having custom fields if they don't work? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...