Jump to content
jppp

custom marionette nodes in vectorworks 2017

Recommended Posts

hi everybody

 

where should custom marionette node libraries be placed in vectorworks 2017? in 2016 they were placed it in C:\Users\username\AppData\Roaming\Nemetschek\Vectorworks\2016\Libraries\Defaults\Marionette but in 2017 this doesn't work and the nodes don't show up in the marionette dropdown user library.

 

jppp

Share this post


Link to post

Hi,

 

All of my custom nodes I now have in a series of separate files that I have placed in the favorites section of the resource manager. They are not in the default node library, but they are still searchable in the resource manager. Attached is a screen shot that shows what the RM looks like for me. You don't have to have a ton of separate files, that is just how I have it set up. All of these files are in my User Folder.

 

-Sarah

Screen Shot 2016-11-16 at 5.26.28 PM.png

Share this post


Link to post

hi sarah

 

thanks for showing how you organized your nodes with the help of favorites.

 

as it seems to me it is not possible for marionette nodes to show up in the resource manager in a user library but only in the favorites. i did the following to test:

 

if i put a file with some symbols in it in the path

 

C:\Users\username\AppData\Roaming\Nemetschek\Vectorworks\2017\Libraries\Symbols\

 

then the resource manager does show the folder "symbols" with my symbol file. But if i put a file with marionette nodes in it in the path

 

C:\Users\username\AppData\Roaming\Nemetschek\Vectorworks\2017\Libraries\Defaults\Marionette\

or

C:\Users\username\AppData\Roaming\Nemetschek\Vectorworks\2017\Libraries\Attributes and Defaults\Marionette\

 

the resource manager will not show that file at all. At the moment i don't understand why it doesn't show the file with the marionette nodes.

 

jppp

 

 

Share this post


Link to post

@jpppHi this video shows how to set up the files so they appear in the dropdown menu.

The same principle applies for 2017, Make sure you batch convert all your files to 2017.

 

 

HTH

Edited by Alan Woodwell

Share this post


Link to post

hi patrick

 

thanks, everything works now as expected! sorry, i did not come across your previous thread where you asked exactly the same question. as explained there i had to convert my 2016 files to 2017 an then refresh the manager. now my custom nodes do show up in the manager as well as in the marionette dropdown.

 

jp

 

 

Share this post


Link to post

@Alan Woodwell

 

thanks for the video! i followed the video earlier for setting up my custom nodes in vw 2016. now the problem was, that my nodes didn't show up in vw 2017 when i did exactly the same as for vw 2016. in order to showing up i had to convert the files and refresh the manager. in addition it seems that the naming policy of foldername$ (folder name followed by a $ sign) makes no longer sense in vw 2017 as the folder name is now visible in the ressource manager.

 

jp

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...