Jump to content

Ganging Tool

Recommended Posts

Ganging tool - I have it assigned to a class on it's own. line weight and color set to green - all good. Problem is the text sits right on the line and makes it difficult to read. I can move the number along the line, but not above or below the line.

checking the container button, it creates 2 containers, one on the line that has no label, and one above containing the label. The empty rectangle on the line will still move back and forth along the line, taking the other label with it, but the label

that actually contains the circuit number won't move independently.

Also, The prefs for the ganging tool does not have prefs for the label font or size Neither does class. How would text size and style and color be changed for these?

I've looked thru archives and not finding any answers, nor online.

Link to comment

I've never seen the two container problem. It may be that you have one container above the line and the text object itself looks like a container?

Try making your own container symbol and typing the name of that container into the field in the OIP. Make the shape have a solid fill and no line.


Probably a dead end, but:

The Ganging Tool is susceptible to taking on current attribute settings at unpredictable times and not being able to change with the attribute pallet. Not sure if this a similar problem. But this may or may not help.

1. Make sure nothing is selected. Check that the OIP says "No Selection"

2. Change Text > Alignment to be the alignment you want.

3. Tools > Utilities > Reset All Plug Ins. Accept the ominous warning.

That's the basic procedure (with a different step 2) for when Ganging Objects grow arrows.


To change the font size, just select the Ganging Object, Text > Size > pick a size. Same idea for font. The ganging tool uses whatever font and size are the defaults when the object is created.



Link to comment

I'll take part of that back. It's totally predictable. The ganging object uses whatever line marker and text alignment are the default when created and will not change in the same way other objects change attributes in VW.

The solution is to change the default and force the ganging objects to reset - either by running the Reset All Plug Ins command or by selecting the ganging objects and changing something in the OIP. Like toggling containers on and off.

This is a bug (I believe I submitted this...), but certainly not the biggest deficiency in the Ganging Tool!



Link to comment
  • 3 weeks later...

Still not finding a solution to this - How do I change the default? I set text and line attribututes, then reset plug ins, no change. ganging is set to be it's own class - so are those settings overridding it anyway? Class settings have green line, and

white fill, which I would assume put the green text on white background, but

text sits right on top of the line, no fill, and is hard to read. selecting "container" puts the number very high above the line, and not able to move it, so is unusable.

What's the answer?????


Link to comment

Here's a sample. one with the text on top of the line, the others have container selected, they wind up somewhere above or below the line, and it's placement

is not able to be edited, sometimes they wind up very high above the line and aren't usable in tight spots.

Link to comment

Yep, I'm seeing the problem now, too.

The ganging tool behaves differently when ganging by circuit than when ganging by dimmer or channel. Not sure why.

This tool has never worked well for all situations. It definitely behaves better when ganging by channel or dimmer than when ganging by circuit. Channel and Dimmer numbers in this example always fall on the line.

Try changing all the ganging object to by dimmer and remove the rectangle from the circuit on the label legend. After that this process will change the relation of the circuit number to the ganging object:

1. Make sure nothing is selected.

2. Text > Alignment > Center (vertical)

3. Tools > Utilities > Reset all Plug in objects

4. Agree to the warning.

The circuit numbers will move around, but not in a predictable or pleasing way.

If you need to use the ganging object, you're better off ganging by dimmer than by circuit.

Make sure you have the latest service pack (SP4).


Link to comment

Thanks for looking at this.

Unfortunately, I have to two-fer by circuit, it's not a dimmer per circuit system.

One thing I have figured out is using a container, a triangle - and setting rotation to 0 degrees or 180 degrees will put the container and circuit number either above or below the line. Can't find a way to have it sit right on the line. Also, the triangle is not big enough to contain 3 digit numbers. I've tried the reset plug-ins several times, but it won't take text format - can't set a white background on the text so a number without a container will read

clearly on the line. I know there has to be an answer to this, can't believe no one is two-fering by circuit.

Again, thanks for the advice.

Link to comment

There is a solution for that.

In the resource browser open the symbol folder "Containers"

Right click on the triangle symbol, choose Edit, choose Edit 2D.

Flip the shape, stretch it, whatever you want.


You can also make your own shape.

Right click on a shape symbol in the Container symbol folder.

Choose Duplicate

Name it Rhombus

Edit the shape to be a rhombus.

In the Label Legend Manager, Rhombus will appear as an option along with circle, rectangle, hexagon, triangle, etc...



Edited by michaelk
Link to comment

So I did finally get the circuit number to sit on the line with a white fill. I can't say how- kept messing with the label legend, for a while I got the number to sit on the line, but the fill was taking up about 3 times the length of the number, so some ganging lines were nearly wiped out by the extra fill, kept messing with the size of the circuit number in the label legend, and somehow got it working, but

absolutely no idea of how. Would love to find some explanation of all this- i.e. if I did want to use a triangle symbol for circuit, how to get the number to actually read inside of the symbol -

Also have another annoying bit - lightwright has added parentheses to the channel number (I use a hexagon for channel). Any idea how to get rid of that,

is it a lightwright pref?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...