Jump to content

VW 12.5.3 to VW2010 creates wall editing problems?

Recommended Posts

I?ve still not figured out why my old VW 12.5.3 docs aren?t allowing me to edit walls and doors in VW 2010. As suggested by tech support, I?m ?dis-associating? dimensions, and then updating and resetting all plug-ins. Once I reverse the plan, then the weirdness begins. What was once a slam-dunk, is now impossible. The walls and plug-in doors won?t move, unless nudged.

Steps I?m following:

1. Open 12.5.3 doc and saving to VW 2010 SP4 (the attached has been converted already).

2. Go to Document Setting>Prefs>uncheck ?Associate Dimensions?

3. Go to Tools>Utilities>Update Plugin objects & Reset all plug-ins>check all

4. Succeed in moving walls, but strangely, the dimensions are still associating.

5. Select all>Reverse Horizontally

6. Walls/ doors won?t move. (also see post on 10/4/10 -#146152)

Sales guy tells me upgrading probably won?t help. So, are my many older drawings pretty much useless in regards to editing for future use? Since I'm mostly only hearing crickets chirping after my original query, I can only conclude that:

1. I?m a bubble-head for not seeing something obvious

2. There is no answer (or it's a secret)

As always, I appreciate any insight from the contributors of this forum.


Link to comment


Our entire office just went from VW12.5.3 to VW2010 and we have had almost no problems, and none related to walls.

I downloaded you file and didn't have any trouble moving the walls around.

Some of the dimensions were associated and moved with the walls.

Others did not. I was also able to move your door around without issue.

Anything else you can tell me about the problem you are having?

Link to comment


Do you or did you have any problems running VW12.5.3 under OS10.6.4? I am curious because when OS10.6 came out, there were rumblings at the time about how VW12.5.3 would run - it sounds like it was OK on your iMac.

Getting back to your problem, and forgive me if you already do iMac maintenance, but I wonder if either your Mac needs a bit of a tune up, or the file is corrupted in some way.

Restarting either VW or the iMac itself sometimes clears problems.

Repairing Disk Permissions (Utilities>Disk Utility>Repair Permissions), and Secure Empty Trash may help.

I also run Diskwarrior regularly, which rebuilds the directory.

I presume you also run Apple>Software Updates.

Before bringing the VW12.5.3 file into VW2010, did you run Tools>Purge Unused Objects, and delete unused sheet and design Layers, etc.? The idea being to clean out any redundant data.

Did you ever import surveyor data straight into the old file? That can cause odd behaviour long after you think you've cleaned it all out.


Edited by D Wood
Link to comment


David, thanks. I do repair permissions routinely and always after each upgrade. I never ran 12.5.3 on OS 10.6.4 and new iMac, hence the reason for the upgrade in April to VW 2010. I have not purged unused objects but will look at that. I always import DWGs/ DXFs into a separate file to avoid corruption. I do, however, move them into working files eventually.


I'm curious, Scott, did you *reverse* the plan attached and *then* try to move walls & doors? I can move things around all day long as long as I don't reverse the plan. I've also run into problems by copying and pasting large pieces of an old plan onto a "new" plan. I'll have to admit the bug seems random, and I've not been able to put my finger on the common denominator. You seem to be doing something right.

Thanks for your help

Link to comment


I used the Flip Horizontal function and had the same problem.

Attempts to drag the wall prompted a message saying they could not be edited do to constraints.

A few people have had this happen in the middle of drafting for no apparent reason. I have not been able to ascertain to actual cause but have been suspicious that there is some default key command triggering it without the user knowing.

That being said I saved a copy of the "reversed" plan, quit Vectorworks, and then relaunched the program. When it re-opened I was able to edit the Walls.

This sort of supports my initial suspicion since restarting the program typically resets it to defaults of the workspace -- but still leaves it a mystery as to the "actual" cause.

Attached is the document "reversed" that I was able to manipulate without changing any of the dimension association settings.

Link to comment

Thanks for the help....

@ Scott

Yes, flipping then quitting VW worked. Odd. I'm just grateful something seems to work. I even tested your trick with a fully annotated "finished" working drawing, with positive results. It is cumbersome, but at least salvages old drawings. I'm scratching my head that more people haven't encountered this problem. Am I the only VW user that reverses and edits older drawings? Nevertheless, you da man.

thanks again.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...