Jump to content
Sign in to follow this  
tkfrmadmin

Vectorworks 12 Crashing

Recommended Posts

Hey folks. I'm having a problem with one of my users here.

Vectorworks Version 12.5.2(71041)

HP dc7700 Tower Computer, C2D Processor, 3GB RAM

Windows XP Pro SP2

Basically is he is using a file (almost all files here are DWGs) for an extended period of time (an hour or more) VW will crash on him. If he saves constantly while working, the problem doesn't seem to happen. I've reinstalled and was hoping you'd have some other suggestions for me. Thanks much.

Share this post


Link to post
Guest

I have the problem when I work heavy between Design & Sheet Layers - It just chrashes constantly. Became used to it.

Share this post


Link to post

2 words of advise ,

" do not accept crashes as being normal"

"Never let the computer win" ... or at least ..not all the time ...

Crashes require diagnosis and repair ... period... end of story.

If it's broke ... then fix it ... small inconsistencies often lead to large dislocations.

Share this post


Link to post
Guest

What is the exact error message you receive?

What are you doing when the program crashes?

Share this post


Link to post

I won't settle for it just happens. Thats BS for software we've payed good money for 5 seats of.

Katie-He doesn't not receive a specific error message. The App just crashes in XP and he has to reboot the machine. No BSOD or anything. He says its not while he is doing anything in particular, just if he has a file open for an extended period of time. It almost seems there is a memory leak in the application. I want to check what he has memory wise on initial start up of VW and his other apps then check the next time it crashes. I'll post that up here as well when I have more info.

Share this post


Link to post
Guest

I'd like him to keep a tab of what he's doing when the program "crashes". I am assuming the application just closes and goes away - is that correct?

What other programs are running on the computer?

Share this post


Link to post

User just had the 1st crash again. Here are some vital stats from Windows Task Manager

Precrash:

52 Processes

685M/4394 MB Memory Used

2301K Memory Available

701K Commit Charge

63K Kernel Memory

Crashed:

46 Processes

740M/4394 MB Memory Used

2425K Availabe

758K Commit Charge

88K Kernal Memory

Vector Works using 100MB Memory and 50% of the Processor

I was able to end the task in Task Man. and restart it fine. Any ideas?

Share this post


Link to post
Guest

Well, let's back up for a minute.

Is the program crashing with an error message, just disappearing with no message, or hanging (still visible but not responsive) ?

Did you have him keep a tab of operations he took up to the "crash"?

This is pertinent information which may lead to resolving the problem.

It would be extremely helpful, especially not having much else to go by, to have this info.

I also asked about other programs running - can you post other programs that may be running?

Share this post


Link to post

Could be wrong... but from those logstats it sure does look like the OS is running dry on both hard & soft memory.

Perhaps, something like a core dump process is gobbling up a space limited .tmp directory. Are you running a server config of some sort ? Or some background PHP processes requiring SQL read/writes ? May be a hidden OS backup or cache backup process ?

VW may have nothing to do with the problem other than being the foremost active process at the time of the crash.

Share this post


Link to post

Other programs running:

Illustrator CS2

Excel

Outlook

Windows Media Player

VectorWorks

There is a SQL service running on this machine for Autodesk Inventor 2008 as well. This might have started happening once he got his upgrade as well.

The program hangs. It can be hard shut with Task Manager and restarted fine.

Share this post


Link to post

Looks to me like there is only 2M RAM available at the time of crash (2301K). If so, I think Islandmon is right. How much actual RAM is on this computer? It looks like you're using 4GB memory with what is running (4394 MB).

Share this post


Link to post
There is a SQL service running on this machine for Autodesk Inventor 2008 as well. This might have started happening once he got his upgrade as well.

This sucker could be the problem if it is making sequential partial downloads or caching improperly to disk as a .tmp file in a .tmp directory.

Share this post


Link to post
Guest

tkfrmadmin

What are the OS specs?

How much free hard drive space, built in RAM, processor type

In the lower right corner is a series of icons next to the clock. What programs are listed here with their icons?

Share this post


Link to post

Kaite,

I m a local IT support person for an architectual firm that is having this same problem. It starts with a Vectorworks application hang, and then it will not start faulting quicktime as the problem. I reloaded the OS for this person and repatched vectorworks to v12.5 with the version of quicktime that comes with V12.0. In less than a week, the vectorworks hung up and and will not start faulting quicktime.qts as the problem. If I completely uninstall both vectorworks and quicktime, includig registry entries, and then reload them, it will run for a couple of days and then hang again. I think its a bug in Vectorworks 12.5. Let me know if you need any more information. Thanks, Mike Casey

Share this post


Link to post

Here is the initial Hang;

Hanging Application vectorworks.exe, version 12.5.2.5505, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

Now, everytime I try to start the VectorWorks applications, I receive;

Faulting application vectorworks.exe, version 12.5.2.5505, faulting module quicktime.qts, version 7.0.2.120, fault address 0x000fb7c5.

Thanks, Mike

Share this post


Link to post

OK, I looked at the initial hang and compared it to the date of all of the files within the vectorworks directory. There is one file that corresponds to the initial crash called Architect-v which looks like a quicktime resource file. I moved that out of the directory and the application started again. Do you want a copy of this file. Let me know. Thanks, Mike

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...