Jump to content


Recommended Posts

VW 12.5.1 on Windows XP

Since updating to 12.5.1 I have been unable to select any visible objects that are not in the active class. Both Class and Layer settings are on SHOW / SNAP OTHERS. Consequently, I have to right click and choose FORCE SELECT. This is getting to be a nuisance. Is this a known bug, or is there some setting I can fix?

Link to comment

I have tried SHOW/SNAP/MODIFY OTHERS and sometimes it works, but mostly not. In effect my VW seems to be permanently set on ACTIVE CLASS ONLY. If no one else is having this problem, I think I'll try to install my backup Preferences in the registry, and see if that helps.

Link to comment

If you are trying to select an object or snap to an object on a different layer, bear in mind that your current layer and the other layer must both be in Top/Plan view for that to work. I do "Align Layer View" when an object on another layer won't select or snap - see if that doesn't solve the problem. Layers in any 3d view (i.e., any view other than Top/Plan) won't allow selection in any layer except the active one. I have never experienced any selection behavior that doesn't conform with the above.

Link to comment

Here are the rules for snapping in VW --

If snapping to objects on different layers, then BOTH layers need to be set to the SAME SCALE and a TOP/PLAN view.

Layer Options must be set to at least Show/Snap others, if not further in the list

Sometimes, it's a matter of snapping to objects on the same layer, different classes. (Or different layers and diff classes)

In these cases, the Class Options needs to also be set to at least "Show Snap Others".

The thing people miss most of the time is either top/plan view OR same layer scale. They are about tied...

Link to comment

All objects I'm trying to select are on the same layer. the drawing is 2D only---top/plan only. Layer and Class options are set on SHOW/SNAP OTHERS. Sometimes when I set SHOW/SNAP/MODIFY OTHERS I can select other classes, but then it goes back to Active Only.

For a brief period after I unchecked the HARDWARE ACCELERATION in Preferences, I was able to select objects in other classes. but now it's back to Active Only.

I have already replaced the registry Preferences file with a backup, but no joy. Is there a Windows Registry setting that I can change manually to make SHOW/SNAP OTHERS the default for classes? I'm getting desperate here!

Link to comment

I have edited Class options in every possible view and viewport.

I thought it was odd that ACTIVE CLASS ONLY would sometimes mysteriously appear in the Class Option dialog, even though I have never intentionally used that option. But changing it back to SHOW/SNAP OTHERS still doesn't fix the non-selection problem.

The keyboard command for ACTIVE CLASS ONLY is: Command+Shift+Option+3. So I don't think I am accidentally hitting a hot key.

Edited by JHEarcht
Link to comment

This is not normal, anytime this problem arises it is one of the suggestions listed here. Just to double check...

Since all objects are on the same layer, did you edit the saved view(s) so that classes are set to Show/Snap/Modify. You can edit saved views by holding the Alt key and double clicking a saved view in the Script Palette.

Link to comment

A VW tech has offered some of the same suggestions, but hasn't looked at the files yet. I have also been having abrupt crashing in another drawing file during panning and zooming. Constant crashing and failure-to-select are not good for my mental health. I'm running out of options; so over the weekend I may have to reinstall VW to see if that helps.

Link to comment

Is all this new behavior since you've installed Vista? (I just noticed that in your tag)

When you talked to Tech Support, did you alert them you are using Vista?

Some of these issues (nudge, etc) are very indicative of redraw issues. It could be the video driver you have in conjunction w/ Vista is not operating at an optimal level.

Does this problem happen with other files, or just this file?

Link to comment

I'm still on XP. Unfortunately, my 2 year old CAD-specific video card is no longer being supported with new drivers.

The reported cause of the crashes is Quicktime.qtr.

The crashing was happening in three separate files on one project. The non-selection happens in a different project and file. However, both files have imported AutoCAD objects, but from different sources.

Link to comment

Did you get the crashing problem resolved?

If not, please alert tech support.

If you copy everything in the non-selection file to a new, blank document, see if the problem persists.

Link to comment

I haven't tried the Gray Others, and such. But I have switched around between ACTIVE ONLY, SHOW/SNAP OTHERS, and SHOW/SNAP MODIFY OTHERS. Sometimes switching to SSMO will allow me to select the object, but the next time it doesn't work. FORCE SELECT will almost always select the object, and change the active class to match.

I sent a file to Gunther at NNA. so far he has covered the same ground as this thread. I have been assuming that the problem is in the file, but "where" is the question. However, if Steve K has a similar problem, it may be due to a bug.

Link to comment

Well, you have to look at both layer AND class options, not just one. And you have to make sure both layers are in a top/plan view - not a plan view. The layers also have to be set to the same scale.

Link to comment
Well, you have to look at both layer AND class options, not just one. And you have to make sure both layers are in a top/plan view - not a plan view. The layers also have to be set to the same scale.

Katie, I wonder why we have to keep going over the same ground? I think it's because those who are contributing complaints here 1) do not make it clear that they understand all of the variables involved in snapping/selection behavior (not saying that you don't understand, just that you are not writing it down with thoroughness) and 2) are not giving enough precise information about what is being experienced. Everyone, could we give Katie a hand? Steve, appreciate that you have given us your system specs, JHE could you also do that? This might be a Mac-only problem.

I have never experienced the problems being discussed except for the following:

- When I have inadvertantly changed my Class Options

- When the object is in another layer and not in Top/Plan view

- When I have pasted an object and its class is set to "invisible" the object can remain visible but not selectable.

- Under certain circumstances, after doing some quick zooming and /or panning, selection handles will not appear. The object is actually selected (confirmed by the OIP), but I have to close the file and re-open it in order to restore handle visibility.

This last situation is a bug, and I have attempted to report it but can't reproduce the sequence of events that leads to the problem.

Link to comment

I have checked all the settings in the threads above, but the problem persists. I have done the following.

Open a new drawing.

Ensure design layer 1 active, and class set to show/snap/modify others.

Draw a circle on design layer 1, Class None,Top plan 2D view at scale 1:1

(I always draw 1:1, and use viewports and workgroup references where appropriate)

Draw a rectangle on design layer 2, Class None, Top plan 2d view at scale 1:1

In layer options, Gray others is ok

In layer options, Gray/Snap others doesn't work (Grays, but wont snap)

In layer options, Gray/Snap others doesn't work (Grays, but wont snap)

Now classes

Set design layer 1 active

Set design layer options to show/snap/modify others

Draw a rectangle on a new class called A, Top plan 2d view at scale 1:1

Draw a circle on a new class called B, Top plan 2d view at scale 1:1

In class options, Gray others is ok

In class options, Gray/Snap others doesn't work, (Grays, but wont snap)

In class options, Gray/Snap others doesn't work (Grays, but wont snap)

Send a copy of this drawing to someone else in the office, and it works perfectly on their machine.

Open one of my old drawings, either from my machine, or from the server, same problem.

I now download the latest copy of Quicktime free edition, problem persists.

Restart my Mac, problem doesn't go away!

During these operations, all my snaps are on.

Have tried Hardware accelerated 2D navigation on and off, still no joy.

This has suddenly happened

Does anyone have a magic bullet solution please!!!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...