Jump to content
  • Error Loading Vision Library


    jblock

    When launching Vectorworks, you may run into this error:

     

     Screen Shot 2019-05-08 at 10.50.07 AM.png

     

    Vectorworks should still launch and operate, but you should be able to fix this by using the following method:

     

    On Windows:

     

    Copy the files in: C:\Program Files\Common Files\Vectorworks 20XX

    Into the Vision folder VW installation folder: C:\Program Files\Vectorworks 20XX\Vision

     

    Unknown-4.png

     

    Mac:

    Copy the files out of ‎⁨Macintosh HD⁩ ▸ ⁨Library⁩ ▸ ⁨Application Support⁩ ▸ ⁨Vectorworks 20XX⁩

    and paste them into the Vision folder in the following location:

    ‎⁨Macintosh HD⁩ ▸ ⁨Applications⁩ ▸ ⁨Vectorworks 20XX⁩ ▸ ⁨Vision⁩

     

     

    Unknown-3.png

     

    This will make Vectorworks ignore the path set by the installer. Vectorworks should now launch without any error.

    Edited by jblock

    • Like 2


      Report Article



    User Feedback


    Hi,

    I have the same problem. Unfortunately the above method does not solve the problem. I still get the same error message!

    Any fix?

    Screenshot 2020-01-02 at 11.40.50.png

    Link to comment

    Hi there

     

    I was so happy when I finally saw a Solution for Windows, but unfortunatly it doesnt help/work.

     

    Are there any other fixes?

     

    Where do I see which path the Installer set? Your quote: "This will make Vectorworks ignore the path set by the installer"

    Link to comment

    Nobody?

     

    When I install Vectorworks on my Master-PC, this error doesnt appear, when I copy the Package to another Computer, this error appears. So somehow I missed some components in my package, but all the Vision-Files are there.

     

    Is there something in the Registry?

    Link to comment
    • Administrator
    6 minutes ago, dwalter said:

    Why cant nobody help here?

    Unfortunately if the steps described above did not fix the issue, we might need to troubleshoot further. I apologize for the inconvenience.

     

    Link to comment

    You guys can also try it by yourself

     

    1. I install VectorWorks on one Computer

    2. To deploy it to many Computers, I just copy the whole Vectorworks 2020 Folder in C:\Program Files and copy it to the Destination Computer

    3. Then I import some Registry Settings

    [HKEY_CURRENT_USER\Software\Nemetschek\Vectorworks 25]

    [HKEY_CURRENT_USER\Software\Nemetschek\Vectorworks 25\Registration]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Nemetschek\Vectorworks 25\Registration]

    4. Place the Vectorworks Shortcut on the Desktop and done

    5. Sometimes I also have to install some missing Distributables

     

    Since about Vectorworks 2018 this Vision-Error Message appears.

     

    Or is there an official deployment method?

    Edited by dwalter
    Link to comment

    I have a new PC and had to install Vectorworks 2020 on my new machine. After installation I had this issue with the Vision Library error popping up and I solved it by uninstalling Vectorworks. I went into my Program Files and deleted manually any folders that remained labeled 'Vision2020'. Then I reinstalled Vectorworks and everything worked fine. I opened and closed the program two times to double check.  However, after the installation, VW prompted me to install the newest 'Service Pack' update. I therefore, clicked on the link to install the newest service pack. This installation caused an issue with the Vectorworks 2020 program which I had just installed, making the program un-openable. I then had to uninstall VW a second time, and reinstall it in a separate folder with a different name. I then registered the product over the internet but I then did not check for the new service pack this time. VW 2020 then worked fine again. I believe that the new service pack is causing the issue. 

    Link to comment

    The above worked perfectly fine for VectorWorks 2021. For me, this error started appearing after I updated to 2021 SP3. It also appeared multiple times every time I exported to MVR (kept having to click to close it, but it didn't seem to have a negative impact on the resulting MVR files). After ensuring VectorWorks isn't running and copying the three folders from C:\Program Files\Common Files\Vectorworks 2021 to C:\Program Files\Vectorworks 2021\Vision, the error did not appear again upon running VectorWorks.

    Link to comment

    This relates to the Vision Library error: 

     

    Recently I did some testing, trying to understand better the relationship between Vectorworks and its creation and use of registry files on Windows and got the following results:

    1. Uninstalled Vectorworks 2020
      • Observation: The registry files under HKEY_CURRENT_USER for Vectorworks 2020 got removed due to uninstallation.
      • Observation: The registry files in HKEY_LOCAL_MACHINE remained in-place.
    2. Deleted all Vectorworks registry files under HKEY_LOCAL_MACHINE only: 
      • Observation: Opened Vectorworks 2021, got ‘Vision Libraries’ error.
      • Observation: Opening Vectorworks 2021 did not regenerate the deleted registry files in HKEY_LOCAL_MACHINE.
    3. I tried several system-related processes in Vectorworks that may have invoked the recreation of these registry files, but none of them worked.
    4. Reinstalled Vectorworks 2021.
      • Observation: The missing registry files in HKEY_LOCAL_MACHINE are now in-place.
      • Observation: The Vision Libraries error no longer appears. 

     

    As I was in the mood to explore, when I reinstalled Vectorworks 2021 I did it over the top of the existing installation. - This practice is not endorsed or supported by Vectorworks Inc and I would never prescribe this method to any user unless it was, but I'm relaying this here just in case a clean installation of Vectorworks does not produce the same result, but I strongly believe it would. 

     

    All this to say that…

    1. It looks to me that the Vision Library error is caused by an absence of, or a disconnect between, the registry file/s and associated files/folders/programs that use them, and that 
    2. Reinstalling Vectorworks should make this issue disappear, but if not, first deleting the Vectorworks registry files within HKEY_LOCAL_MACHINE then reinstalling should do it. 
    Link to comment

    @jblock This worked for me, thank you.

     

    When I installed VW 2022 it completely messed up my 2021 - reset everything to default, removed all my workspaces and favorite files, and I started getting this error.

     

    At least this was a simple fix!

    • Like 1
    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...