Jump to content

Crashing when Rendering

Recommended Posts

I have a file that crashes when I use Final Quality Renderworks

I tried to use custom renderworks and it seems that when I set it to High, Transparency On and Anti-Aliasing on, it crashed

If I lower to "Low" or turn off either Transparency or Anti-aliasing, it renders without crashing but does not look good

The error I get is:The application Vectorworks has unexpectedly quit, because an error type 2 occurred.

I am using a Mac Notebook 400 with a 30gig HD and 576 megs of RAM

I can render at final quality in other files but not in this one

This file renders fine on all other machines I have tried it on, except for the notebook

Any ideas?


Link to comment

Okay, wait...I've also heard (from Katie & others) that you can allot (sp?) TOO much and not leave enough for the Mac system (which must perform some mighty fancy stunts in the rendering dept.). But when it comes to these (computer) things I'm never quite sure. Sometimes things fix themselves and I'm not sure how or why either. Hope you work it out, PLC

Link to comment

Ah... this sounds like one of my favorite bugs.

I'm going to bet that one of the textures in your file is a combination of a transparency shader and an image color shader.

At the moment, there is a bug in the lightworks rendering engine that we use which will cause VectorWorks to crash with this combination.

Instead of using an image color, try using a plain color or object color which is a close match.

Matthew GiampapaNNA Technical Support

Link to comment

Lonnie, Go back and check the memory allocation settings for the min and preferred. I like to se the min to the same as the suggested. Then I set the preferred to about 100,000 -250,000 depending on the size of the file. You should never need more than 250,000 unless you are working with a large drawing and many light objects (not the same as light instruments in Spotlight).

Try to change your mem allocation settings to something a little lower.

An error type 2 is usually a memory allocation setting problem. If memory isn't the problem, then there could be a conflict with extensions.

Link to comment

As for the RAM allocation, Yes it is probably a bad idea to allocate all of the memory on a machine to VectorWorks. The MacOS system heap expands and contracts dynamically, and if everything is being used by VectorWorks, it can be very difficult to perform some operations like exporting an image.As a general rule, I allocate about 60% of the memory on a machine if I'm doing something memory intensive. Otherwise I leave it at about 30%. (Of course I also have about 20 things running in the background at the same time, so ymmv)

If this is happening on just your laptop, there is also the possibility that there is some kind of extension conflict at work here as well. They are frequently the cause of a type 2 error in VectorWorks. Try going to the Extension Manager control panel, and using the MacOS All extension set.

Matthew GiampapaNNA Technical Support

Link to comment

Matthew and Katie

Thank you so much for the responses. This computer is actually my Students and as I do not use Mac, I am hoping all of this makes sense to her

I will pass it along and see if it fixes it.

The file renders fine on my PC notebook, so I am thinking it is probably memory allocation, unless the Image Color bug is specific to Mac

Thanks again


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...