Jump to content
avictorgm

substitute custom symbol with attached databanks curious problem

Recommended Posts

Hello again,

 

I have 2 different named symbols

every symbol is attached to his own databank with different names.

when I replace the symbol both databank stays active in the Information window / Data.

 

And I can write some numbers inside the 2 of them.

 

Can somebody explain this ?

Share this post


Link to post

It is just how records are attached to symbols.  The symbol is not the "object", so if you replace the symbol, the "object" and any records attached are not changed.

 

When a symbol definition has a record attached, and that symbol is inserted into the drawing you get a symbol instance with an instance of the record attached that contains all of the data from the record attached to the symbol definition. The record attached to the symbol is then no linked in any way to the record attached to the symbol definition.

 

So when you insert the first symbol, the instance gets an instance of the first record attached.

 

When you replace the first symbol with the second, you get the second symbol plus an instance of the second recorder attached to the "object". The first record is still attached to the "object" that is having the symbol replaced. 

 

So now the "object" has both records attached.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×