Jump to content

Recommended Posts

Hey, so I am a complete beginner at Vision, but through the help of the lovely forums and videos and instructions, I've started to get the hang of this.

One problem now though: my beams of light appear to be going through walls and I have no idea how to fix this!

I have already made sure my textures cast and receive shadows in my VWX file, as well as my lights.

 

Any ideas?

 

going thru walls forum help 9.19.2018.PNG

Edited by Cadesence

Share this post


Link to post

The "Enable Shadows" document preference is now disabled by default because (you'd never believe me when I say this) most people don't notice they are off and the performance increase is astounding.

 

Simply select ROOT and check the "Render Shadows" check box 😉

 

One last note (kind of tying in to what I said earlier), if you can run in realtime without shadows it will run WAYYYY faster. You can always toggle the shadows on and off in realtime mode to see what you need to see when you need to see it. I would recommend always enabling shadows for Rendered Stills and Rendered Movies.

Share this post


Link to post
46 minutes ago, bbudzon said:

The "Enable Shadows" document preference is now disabled by default because (you'd never believe me when I say this) most people don't notice they are off and the performance increase is astounding.

 

Simply select ROOT and check the "Render Shadows" check box 😉

 

One last note (kind of tying in to what I said earlier), if you can run in realtime without shadows it will run WAYYYY faster. You can always toggle the shadows on and off in realtime mode to see what you need to see when you need to see it. I would recommend always enabling shadows for Rendered Stills and Rendered Movies.

 

Thank you for replying so quickly! I did check that box, but it still goes through?

 

going thru walls forum help 2 9.19.2018.PNG

Edited by Cadesence

Share this post


Link to post

I think I know what's going on. Go into your application settings (not document settings) and make sure Dynamic Shadows is set to "Objects".

 

Screen Shot 2018-09-19 at 10.02.41 AM.png

Share this post


Link to post
34 minutes ago, bbudzon said:

I think I know what's going on. Go into your application settings (not document settings) and make sure Dynamic Shadows is set to "Objects".

 

Screen Shot 2018-09-19 at 10.02.41 AM.png

 

Uhhh, sorry for having to ask this, but how does one get to application settings? ^^ ''

Share this post


Link to post

On OSX, you can click the Vision menu and then click Preferences (on PC it is Edit->Preferences). You can also use the default OSX keyboard shortcut that is used by all applications on OSX: Command+, (note: this keyboard shortcut does not exist on PC).

 

If you were unaware of this menu, make sure to check the help documentation, as well. There is a LOT of good stuff in there and you should try to understand all of these settings as they have direct impacts on performance and quality.

 

The settings that impact performance the most (and in order of importance):

  1. Resolution Quality
  2. Volumetric Quality
  3. Render Fixtures (with large number of lights)
  4. Shadow Quality
  5. Texture Quality
  6. Dynamic Shadows (should almost always be set to "Objects", which should be the default)

We tried to ship mostly sane defaults here, but feel free to try these settings out and store them off as presets.

Edited by bbudzon
Clarification

Share this post


Link to post
2 minutes ago, bbudzon said:

On OSX, you can click the Vision menu and then click Preferences (on PC it is Edit->Preferences). You can also use the default OSX keyboard shortcut that is used by all applications on OSX: Command+, (note: this keyboard shortcut does not exist on PC).

 

If you were unaware of this menu, make sure to check the help documentation, as well. There is a LOT of good stuff in there and you should try to understand all of these settings as they have direct impacts on performance and quality.

 

The settings that impact performance the most (and in order of importance):

  1. Resolution Quality
  2. Volumetric Quality
  3. Render Fixtures (with large number of lights)
  4. Shadow Quality
  5. Texture Quality
  6. Dynamic Shadows (should almost always be set to "Objects", which should be the default)

We tried to ship mostly sane defaults here, but feel free to try these settings out and store them off as presets.

 

OHHH. HA! I was aware of this menu, for me, it's Vision Preferences, not Application Settings (though they may mean the same thing, idk)

And I will make sure to help myself to all the help documentation as well!

 

By the way, it worked!

Thank you so much!

  • Like 1

Share this post


Link to post

Glad to help! You are right about the menu not being called Application Settings but we will refer to the settings in that menu as Application Settings because they are stored in the Application and NOT in the Document. Similarly, Document Preferences (such as Render Shadows) ARE Document Preferecences and therefore will be stored in the v3s. When you email Vision files to others, the Document Preferences will carry along but Application Settings will not as they are set on a per user basis inside the Application itself. (This is similar to how VW handles Application/User Settings vs Document Preferences.)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×