Jump to content
Sign in to follow this  
HalTDavis

Intermittent Render freezing

Recommended Posts

I opened a new file, blank.  I used a basic wall.  I rendered in several different modes.  It's not renderworks.  It's my file.  At first, it worked, and I'm guessing the polygon styles don't like textures.  I also have a lot of collisions between my own extruded spacers and it may be that the polygon renders are having trouble with those.  I tried with and without Admin rights.  Oddly enough, without admin rights everything processes through open gl a lot faster.  If both VW and RW are set to normal compatibility, it's fast.  I'm going to guess that there's a system check that occurs in the function to startup the render, then in each function that calls system based api's rather than the RW api.  This causes small but noticeable drops in opengl.  The coolest part though is that opengl will render out just fine, and I ran a benchmark on my cards, my intel cpu gets every message, but only outputs about 1\4 of the info back into the program, while my NVIDIA GPU (980m) will output the rest, and still get it all.  My best guess here is that SLI or and IRIS variant is running in the background to balance the weight across the two.  The memory processes when the crash occurs fill up with error data, and neither processor does anything.  It has to be the textures.  I'll turn them off.  I don't need them so much, only to visualize differences in objects.  Perhaps a solid color can provide that.  

Textures that are 2d and placed on 3d don't work well with polygons that are colliding so much (overlapping).  That's why they have such a problem.  I'm uploading my project file.  Check the spacers between the child models.  They have a class texture applied.  Try rendering.  It may be that the latest version of renderworks does not like my work there.  No biggie for me, but others may have a problem.

Disney_Stage.vwx

 

Update2:

More testing reveals the culprit.  Check your classes and layers for any settings that apply patters with opacity shading added (IE turning down the opacity from 100 to something lower).  The pattern and the shading won't work together.  If you use a solid color, it will work fine.  Textures won't work either.  However, if you send it to a full rendering with all lighting and adjustment, it seems to work fine.  The render engine for the pattern and opacity seems to error out.  I tried removing them but it still wouldn't render, then I removed the classes and anything they actually affected.  It rendered once, then when I did it again, crash.  It's a memory leak alright, but where is still unknown.  At some point in the render, it's still finding the error data.  Best to PURGE anything unused and try again.  The file here is the broken one.

 

DO NOT RENDER PATTERNS with polygon settings, do not render patterns at all with opacity, this fails even with opengl or renderworks styles.  If you're going to render them with patterns or texture, I suggest you save the texturing and patterning steps for the end.  I rebuilt the entire file from scratch.  Without the patterns, everything renders fine.

 

Problem possibility 2:

When closing the device for sleep, leave the files open in vectorworks, or if you shut it down, shut down the entire computer.  I closed it up and it probably prevented some of the data from being unlocked by the program (database files end up locked while their being worked on, and what you actually edit is an editspace which applies at the next save operation;  this allows the system to hold a pagespace of memory for the database file, and an open memory space with a pagespace backup for your edits; when edits are made, they are tagged onto the end of the database pagespace, and then the file is rewritten when all access to the file is closed; most apps like VWX use exclusive access for standard desktop clients, and shared access for larger server connections, allowing the maintenance of the file to run when the access to the file is closed out from the last machine accessing it, or at a set time for servers).  I may have inadvertently prevented the rewrite in some fashion or broke the file linkage somehow.  But the graphics stuff I outlined above shows up in new files too, so it's definitely a possible cause for my problem, and likely yours.

Edited by HalTDavis
More testing done

Share this post


Link to post

After reading this tread I realize there is no mention of .........attempting to render the scene in design layer or by using viewports?

Share this post


Link to post
8 hours ago, Luis M Ruiz said:

After reading this tread I realize there is no mention of .........attempting to render the scene in design layer or by using viewports?

I tried it today with a new file. I rebuilt everything in the old file.  For some reason, the polygons are acting up again and it isn't my broken file.  Somehow, the rendering engine is fouling up, possibly due to the number of objects, I can't be sure without knowing more about the engine's limitations.

I did put in cameras, tried the renders again, and again the polygons hated me.  However, OPENGL worked fine.  I even set the render settings high and it worked really fast.  Check to make sure that your objects are not grouped in weird ways, or that your classes conform to norms.  It may be something to do with that.  Again, I can't be sure.  I tend to reclass every set of objects to it's own class, and then put similar design elements (similar purpose) into the same layer so I can change how I work with the objects very quickly (altering class to only the active allows me to see all of one type of object so I can move them around; prevents grouping problems).  This method worked at first with one or two objects, but I'll admit I've got 40 children placed.  OpenGL has a cleanup designed to limit memory leakage where the polygon shaders don't seem to.

From the Cameras, I created viewports and only opengl worked.  I stuck with it.  I'll try other renderworks styles later, but I get the feeling I'd be better off sending to Cinema4d for a full render.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×