Jump to content
Sign in to follow this  
Leonard Marsh

Mac PB G4 & VW10 whacky behavior

Recommended Posts

Any help with this problem will be greatly appreciated.

The Whacky Behavior with a PB G4 (1gig/1gig storage):

1. Selecting an area with the pointer, the pointer erratically alternates between arrow and hand, does not create the dashed marquee and partially disassembles the target object. With symbols, there can be a sudden shift from the document to the symbol "edit" mode without going through the Resource Browser>Resources>Edit. Similarly, with grouped objects, it will jump into Edit Group without using the menu process.

2. Selecting an area to zoom into suddenly results in an unintended jump to the max zoom in.

3. When using the Pan Tool (hand), after releasing the mouse, the document continues to move across the screen.

Attempted fixes:

1. Trashed the two known preferences.

2. Twice trashed the application and known preferences and reinstalled first to VW10.5.1 and then to VW10.5.

3. Switched Turbo Mouse to an Apple Mouse.

4. Thinking that the document was corrupted, I cut and pasted into a new document.

5. Ran Disk Utility to repair the preferences,ran Disk Warrior and ran Norton Utilities Disk Doctor and Optimization.

One last note, when this file is moved to a G4 tower machine, which is an 800mh/1+gig storage machine, none of these behavioral problems occur.

TIA.

L.

Share this post


Link to post
Guest

When selecting an area when the arrow jumps to the hand, have you pressed the space bar?

The space bar is a keyboard shortcut to pan. (the hand looking tool behind the arrow)

When zooming, if you double click on the drawing, you may zoom in more than you want.

You can marquee to zoom or you can double click in the drawing.

What version of VW are you using on both computers?

What OS are you using (on both computers) ?

Share this post


Link to post

Hi Katie,

Thanks for responding.

VW version: 10.5 and 10.5.1.

OS X version: 10.2.8 on both machines.

Regarding the zoom & hand tools, I know VW/RW fairly well. I cut my teeth on MiniCad4 and have stayed with it since.

The strange behavior is the way I've described it and my use and operation of VW/RW & the computer is the same regardless of the computer. It occurs on the laptop and not on the desktop computer. Strange!

A question I have for you: I trashed the preferences "VectorWorks 10 Prefs" and "net.nemetschek.VectorWorks.plist" during my attempted fixes, are there any other preferences, etc. I should have trashed?

Thanks again.

L.

Share this post


Link to post
Guest

There are no other preferences, but if you haven't run Disk Utilities First Aid in the Applications:Utility folder, that may be your problem.

Share this post


Link to post
Guest

Im close to being stumped.

When you ran disk utility, did you run it from the CD or from the hard drive?

Did you verify and repair, or did you just verify?

Do you have any programs running on the PB that you don't have on the other computer?

Sorry for not recognizing your efforts originally. I am stretched .. :-) but I enjoy stumper questions.

Share this post


Link to post

I did battle with the erratic behavior again today! Painful.

To answer your questions, I ran the disk utility from the hard drive because my OS X upgrades have been from the internet and not from a disk. I both verified and repaired. Both machines are loaded with the same programs. I neither added applications nor upgraded any applications prior to this problem. Also, this behavior occurs when VW is or is not the only open application.

The problem sounds like an application conflict issue but what do you think about upgrading the OS to 10.3.3?

Thanks.

Share this post


Link to post
Guest

10.3.3 works with just VW running alone as our daily work in it seems to show that. However, it's only been officially tested on it's own, not in relation to other applications. If there are other significant applications you run, you may want to check with those vendors before updating.

How often do you restart the computer?

Share this post


Link to post
Guest

About how long does your computer run after restarting through the time the problem crops up again?

Do you have the mouse plugged into a non standard OS keyboard or is it plugged into a normal keyboard or the back of the computer?

I seem to remember a problem like this happening when I had the mouse plugged into a MacAlly keyboard.

Share this post


Link to post

I generally do not restart any of the three Macs I use VW/RW on unless there's a freeze or bomb. And, that would be a temporary fix for the laptop, yes?

If I did not make it clear, when this problem occurs, at least 90% of the time, only VW/RW and OSX are running, upfront or in the background. I'm certain it is not VW/RW or the mouse, independently. The conflict could result from interactions between VW/RW with invisibles, fonts, the OS X, etc.

Additional behavior expamples: Dragging to select nested group objects sometimes causes an abrupt switch to "Edit Group" and deconstruction of the group, which I then have to stop, "Undo" and click on the "Exit Group" button and try again. Other times, a dialog box opens to inform me that the selected object is not bona fide/editable. My apologies for not having the exact wording.

If I do not hear from you, have a good weekend.

L.

Share this post


Link to post

Hi Katie,

I just wanted to close out this question. I upgraded from OS X 10.2.8 to 10.3.3 and the strange behavior seems to have disappeared. I will be using the PB a lot more and if there is a reoccurrence, I will get back to you.

Thanks for the help.

Cheers,

Leonard

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...