Jump to content

redl

Member
  • Content Count

    13
  • Joined

  • Last visited

Everything posted by redl

  1. Oops the screenshots didn't upload (I hope they appear now)
  2. Hi ! I'm trying to use road objects to modify my DTM. My DTM works and displays well when unmodified. But as soon as I use roads to modify it, some contours are clipped. This problem makes it impossible to display the DTM in "extruded contours mode" (in 3D). The triangulated mode works well. I tried to simplify my curves, but it didn't help. I also regenerated the road, still without success... Did someone of you encounter the same issue ? Is there a workaround ? Thanks ! Olivier (VW Designer 2010, Mac OS X.6.6)
  3. Thanks for all your answers ! I wasn't expecting that much since my post was a bit aggressive I read all of them, and it helped me a lot. It's still not perfect, but I can get a bit more of my model. I'm still stuck at something : I'd like to draw altitude markers on my sections (for instance altitude of the building's roof). But the section's annotations coordinates seem to refer to the paper space instead of the model space. Is this possible ? And here's feedback about your tips. So, I can choose between the floor object, where I can add/substract surfaces (which is didn't know and is nice) but not edit the points in context, and a building object where I can move the points in context but not add/substract surfaces. I've read about this bug, but here it does not act like this. The sections keeps the same color, no matter the current attributes. And if it's a known bug, why hasn't it been fixed ? Didn't we pay for our software ? When I set my DTM to be only a triangular surface (and not a solid mesh), the section displays with a small fill which makes it ugly and unprecise (see attached file). When I set my DTM to be a solid, I can't see my underground floors anymore. The only solution I found is to decompose the DTM in 3d polygons. Then it works well (and is faster), but I loose all the parametric aspects of the DTM (or have to manage a copy of the DTM). Here, the "zoom on page" zooms on the perspective square, and the "zoom on objects" don't do anything at all in perspective. (works well in parralel projection though). Another good tip, but changing the origin would make me loose the benefit of being georeferenced. My drawing is based on surveyor's data which is subject to change. I overlooked the "set 3d view" command which helped me finding my model. I can navigate with the walkthrough tool, but it's not very practical since the model is very slopy. Isn't there a "fly through" command ? I'm on Mac with a 2 years old iMac. On this point, you have to admit VW IS slow. I loaded the same DTM in sketchup, it took quite a long time to build, but once built, I could move the section through the terrain in real time. I am quite computer savvy and I have a very good knowledge about 3D and CAD programs (I use a lot cinema4d, archicad, sketchup, ...). And I know VectorWorks quite good now (the 2D aspects). Still, the 3D functions are really cryptic, old-fashioned and hard to grasp. Of course it takes some time to get good at any program, but in this particular case, I don't think the learning curve is justified by the capabilities of the program. It's just old-fashioned and counter-intuitive. You can't blame the user for that... It needs a serious refresh.
  4. Hi ! I work in an urban planning office in Switzerland and VectorWorks is our main tool. We use it for quite a while and are satisfied with it as long as we work in 2D. However, we are now wanting to use the 3D capabilities of VectorWorks (2010) to do some modeling (DTM + very simple buildings consisting of stacked parallelepipeds). I almost want to cry seeing how bad VectorWorks is in doing such a simple task. It is bugged, slow and feels terribly out of date. 1) It seems not possible to have simple extruded polygons which display in plan view AND in 3D view with a solid color. I found out that the "floor" tool does it, but it's a pain in the *** to use. (you have to create it from a polygon and then run a function, you can't move it's points nor split it without viewing it in "group" mode where all other objects are not visible, etc...) 2) The section tool is a bad joke. There is no way to choose the style of the DTM in section ! You can only choose its solid fill color... When you explode the section viewports, the section disappear... Copying sections is a total mess since it duplicates the section mark on the model layer (actually on a random layer). You have to reconfigure every new section manually, because copying attributes does not copy the attributes, but resizes and inverts it ! You can't rename a section. 3) Viewing the model is ultra-counter intuitive in perspective. I didn't manage to find my model !! You can't zoom on selection... So I can look at it only in axonometry, which makes it almost impossible to use to have a "in site" feeling. I thought that was the main purpose of a 3d model ! 4) The 3D display is very laggy. I opened the same terrain in several other tools (autocad, cinema4d, sketchup), and it was totally fluid in all of them. The DTM takes ages to regenerate, even if you only change a minor display element (like a stroke color). 5) The is a very good function which allows to create a terrain section and showing the new and old terrain shape, but impossible to display the buildings on it, which makes it useless. You also have to delete the results and rerun it for each change on your DTM. And so on... Well, all this to say I'm not happy at all with VW and it's 3D tools. There is a LOT to improve. It's quite a pity, individually, each function works quite well, but even after a few days of trying and reading on internet, I haven't been able to make my workflow fluid. I feel like I'm using a program coming from the age of the punchcard... I'd of course be very glad if someone has some tips to improve my workflow. Best regards, Olivier
  5. OK. Is there a plan to have a patch ? I also noticed that sometimes a rectangle gets created which seems to have the same size than the page. However, I didn't understand how to make that on purpose (maybe it's a keyboard shortcut)
  6. Hello, I'm using Vectorworks 2010 and I have a frustrating issue. In my presentation sheets, it seems possible to snap to the page's corners, which is of couse useful to draw a frame or to align my drawings. However, this particular snap is very unaccurate and makes it almost unusable. I joined some screenshots, showing what happens when I use the snap, and then zoom in. Incredibly, the more I zoomed in, the more accurate the snap is, but if I zoom in too much, it doesn't snap anymore... Do you have the same issue ? Is there a workaround ? And by the way : is there a way to have different units on my presentation sheets and on my drawing sheets ? (meters in the drawing sheets, millimeters in my presentation sheets) Thanks for your help !
  7. redl

    Dynamic clipping

    Possible uses : - complex pavings (so you could still change the global shape of the paving because you wouldn't need to trim it) - regular layouts (you could have a regular layout of parkings lots or furniture to adapt to a surface, eventually with an option to hide partially trimmed objects) - clipping complex objects (for now, there is no way to hide some parts of a complex object (symbol, PIO, ...) without having to convert it to polygons, which makes it loose it's parametric quality). More globally, the most interesting aspect of a clipping path is that you can move/scale/rotate the content independently from the boundaries. In Photoshop they are called masks, in Illustrator clipping path, in Indesign it's the frames... They really are very useful ! I don't know why they don't make them in CAD software...
  8. redl

    Dynamic clipping

    Am I the only one to think it's worth investigating ?
  9. redl

    Dynamic clipping

    Ok. But isn't using a viewport for such a simple thing a bit clumsy, especially if you have to crop several elements on several places in your document ? Here's the script I got so far (unchanged since last post). Does someone know why it is "flickering" ? (the clipping is very unaccurate and changes on every recalculation) Thanks ! PROCEDURE ClippingMask; VAR plugN: STRING; plugH, recordH, wallH, profileH, pathH: HANDLE; vertexNum, vertexType, I: INTEGER; H, pX, pY, arcRadius: REAL; handleToObject,otherHandle,voidHandle : HANDLE; dX, dY, dZ :REAL; {THOSE VARS ARE USED TO GET THE PARAMETERS} show_path: BOOLEAN; show_clip: BOOLEAN; {THOSE VARS ARE USED FOR ATTRIBUTE COPY} source, target: HANDLE; r, g, b : LONGINT; temp_b : BOOLEAN; temp_i : INTEGER; BEGIN show_path := PSHOW_PATH; show_clip := PSHOW_CLIP; IF GetCustomObjectInfo (plugN, plugH, recordH, wallH) THEN BEGIN pathH := GetCustomObjectPath(plugH); profileH := GetCustomObjectProfileGroup(plugH); {GET THE ORIGIN OF THE PLUGIN OBJECT} GetSymLoc3D(plugH,dX,dY,dZ); handleToObject:=FInGroup(profileH); WHILE handleToObject <> NIL DO BEGIN otherHandle := ConvertToPolygon(handleToObject, 64); vertexNum := GetVertNum(otherHandle); FOR I := 1 TO vertexNum DO BEGIN GetPolylineVertex(otherHandle, I, pX, pY, vertexType, arcRadius); {WE MOVE THE POLY POINTS BY THE PATH's POSITION SO THAT THE PROFILE ELEMENTS STAY AT THE SAME ABSOLUTE POSITION} SetPolyPt(otherHandle, I,pX-dX, pY-dY); END; voidHandle := ClipPolygon(otherHandle, pathH, 1.0); {BEGIN ATTRIBUTE COPY, source:http://www.vectorlab.info/index.php?title=Attr-Attributes_copy} source := otherHandle; target := voidHandle; IF (target <> NIL) & (source <> NIL) THEN BEGIN SetClass(target, GetClass(source)); IF IsLSByClass(source) THEN SetLSByClass(target) ELSE SetLS(target, GetLS(source)); IF IsLWByClass(source) THEN SetLWByClass(target) ELSE SetLW(target, GetLW(source)); IF IsPenColorByClass(source) THEN SetPenColorByClass(target) ELSE BEGIN GetPenFore(source, r, g, b); SetPenFore(target, r, g, b); GetPenBack(source, r, g, b); SetPenBack(target, r, g, b); END; IF IsFPatByClass(source) THEN SetFPatByClass(target) ELSE SetFPat(target, GetFPat(source)); IF IsFillColorByClass(source) THEN SetFillColorByClass(target) ELSE BEGIN GetFillFore(source, r, g, b); SetFillFore(target, r, g, b); GetFillBack(source, r, g, b); SetFillBack(target, r, g, b); END; GetOpacityByClass(source, temp_b); IF temp_b = TRUE THEN SetOpacityByClass(target) ELSE BEGIN GetOpacity(source, temp_i); SetOpacity(target, temp_i); END; END; {END ATTRIBUTE COPY} IF show_clip=false THEN BEGIN {WE HIDE THAT BY SETTING ATTRIBUTES (could also delete them)} vertexNum := GetVertNum(pathH); SetLS(source,0); SetLW(source, 0); SetPenFore(source,0,0,0); SetPenBack(source,0,0,0); SetFPat(source, 0); SetFillFore(source, 0, 0, 0); SetFillFore(source, 0, 0, 0); SetOpacity(source, 0); END; SetSelect(source); MoveBack; handleToObject:=NextObj(handleToObject); END; DSelectAll; IF show_path THEN BEGIN vertexNum := GetVertNum(pathH); BeginPoly; FOR I := 1 TO vertexNum DO BEGIN GetPolylineVertex(pathH, I, pX, pY, vertexType, arcRadius); AddPoint(pX, pY); END; EndPoly; END; END; END; Run(ClippingMask);
  10. redl

    Dynamic clipping

    I did not think of using a viewport... However, it seems that you need a Designer license to be able to put a viewport on a design layer, and I think that even in this case you would need to create a dedicated layer for the content you want to crop (which can quickly lead to an over-complex document). I'd just like to be able to clip the content of a group. I'm currently trying to code this, and I've already some interesting results. But it's still heavily buggy. Be careful if you try it, i crashed VectorWorks several times. I joined what what I've got this far. To use it, you put the clipping path in the path, and the clipping content in section of the custom path object.
  11. Hello, Much like clipping masks in illustrator, I'd like to have a dynamic clipping object which would consist in : - a set of objects (base) - a clipping path (mask) And which would display the part of the objects that are inside the clipping path. It would have exactly the same result than the "clip tool", except that the base objects would remain untouched. This would allow to clip some complex objects (for instance thick dashed lines) without loosing their parametric aspect. Does this already exist ? If it does not, is it possible to make such a plugin using a Path-type plugin object ? (I'm quite new to VS, so I'm not sure of its capabilities). What do you think ? Is it worth investigating ? Thanks !
  12. redl

    GIS annotation

    Hi, Thanks for your answer. Our distributor is ComputerWorks AG. As I said, the data imports very well : I'm able to see it in the data tab of the OIP, to list it in a worksheet, and so on. However, as I said, I can't find how to use that data in my drawing (a basic symbology). In some cases, I'd like to display a text label on my elements (for instance write the parcel ID). In some other cases, I'd like to set the graphic attributes of my elements (for instance, set the color the yellow for residential zone types, to blue for commercial zones, etc.). If it is possible to do that with Vectorworks 2010 out of the box, you could just point me to the right manual page (or describe shortly how to do it). If it needs to be scripted, you could provide some clear and easy to adapt example scripts (you can use any generic data to show the example). By the way, I have another (less important) question about the GIS capability of vectorworks (especially 2010). Is there a way, as there is in any GIS software, to have computed data ? For instance, if I've got the number of resident of a parcel, I'd like to compute the density of the parcel (nbr of residents / parcel area) and use that data as any data. I know it is very easy to make computed columns in the worksheet, but is it possible to use them in VW ? It does not seem possible to use that with the "defined selection tool", and it does not seem possible to save the computed columns back into the database. That would also be great and almost allow to avoid the use of a GIS software besides VW for simple operations. Best regards, Olivier
  13. redl

    GIS annotation

    Hello ! I?m trying to use the GIS capabilities of my VectorWorks 2010 version (designer). The data imports well from .shp files. However, I can't manage to label my elements. On the whitepaper ( http://download2.nemetschek.net/www_misc/2010/VW_GIS_Whitepaper.pdf ), I read : I?ve searched in the reference manual, on the forum and on google, but I did not find how to do this. I'd like to be able to display the area name, or it's area, or whatever information associated in the database. If possible, it would also be great to be able to set the color of the element depending on database values (for instance, every shape where a certain attribue is btw. 0 and 1 => dark blue, btw. 1 and 2 => blue, btw. 2 and 3 => light blue, etc.) Can you help me ? Regards, Olivier

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...