Jump to content
Developer Wiki and Function Reference Links Read more... ×
Stefan Bender

VWWallObj::InsertNewComponent sets cavity thickness to 0???

Recommended Posts

Dear developers,

have any of you ever used VWWallObj::InsertNewComponent or ISDK::InsertNewComponentN? I'm currently trying to "copy" the cavities of an existing wall that has 3 cavities (with a total width of 32 cm) to another wall with no cavities but a width of 45 cm. I'm adding 3 cavities/components seemingly sucessfully to the target (after reading them from the "source" wall by VWWallObj::GetComponentInfo), but when I analyze the "target" wall, all three cavities have a width of 0 and the overall width of the target wall is 0. The expected and required result is that the "target wall" has the same components and the same overall width as the source wall afterwards. I assume that the problem may be related to the fact that the target wall had no cavities before this. But I couldn't find an object variable or member function of VWWallObj to tell the wall that its width is defined by components and not by "width". Is there something wrong with my workflow? What can I do to make the target wall "accept" the actual widths of the cavities?

 

Thanks for any help,

 

Stefan Bender

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×