Jump to content

joesnikon

Member
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About joesnikon

  • Rank
    Greenhorn

Personal Information

  • Location
    United States
  1. @DomC Thanks for the tip. Zeroing out the vector input didn't work, but disconnecting it did. Part of my problem (and I have many) in learning how to use the various nodes, is that not every node's description makes it obvious as to what's expected. Sometimes it's just trial an error for me. The good news is that your rectangle tool worked exactly as expected.
  2. Hi Pat - I did try to copy the script into a new document. I even created a new document and started the script from scratch. Neither one of these options worked. Interestingly enough, every other rectangle related node works fine, including creating a rectangle with 2 points. M.graf, I'll try the enhanced rectangle tool from DomC. Thank you.
  3. Nope, tired that 2d input point too... nothing. I've been using the rectangle node regularly, without issues, over the past week as I've been learning my way around Marionette. This seems to coincide with the locking up of one of my files. I've tried restarting both Vectorworks and my Mac but haven't had any luck. Every other object node works exactly as expected - but not the rectangle node.
  4. As a follow up to my last question - The rectangle node stopped working. I can create every other type of object, no problem, but the rectangle tool produces no results. When I enter debug mode, the inputs display the correct values but the output of the node remains emptyrectangle.vwx (0). This loss of functionality occurred at the same time as my previous problem/question.
  5. I'm using Vectorworks for Mac and learning my way through using Marionette. I got into this odd situation where the file that I was using to create and practice my script development keeps locking up Vectorworks. I've tried resetting both Vectorworks and my Mac, but no luck. The lock up occurs specifically when I try to select the black rectangle in the middle of the page - it was created using a very simple script. I'm hoping to be able to get back into this file, as it has a couple of symbols that I spent a fair amount of time creating. Thank you. Symbols.vwx
  6. Thanks for the response M.Graf, but I'm not completely following. I dissected what you sent me but I can't find where a change has been made. Also, the file I previously included didn't have one of my wrappers attached - I've re-attached the file. As you'll see the script on the left works fine - it allows me to convert it to an object node. The script on the right is the one that comes up blank. The only difference is the inclusion of one wrapper ("Add_Move_Attribute"). Symbols.vwx
  7. I created a Marionette script that creates a 2d downlight symbol with a rotatable arrow and moveable text - works fine. Placed it in a wrapper - still works. But as soon as I attempt to convert to an object node, I get nothing, just a blank screen. I'm a total newbie that started learning Vectorworks and Marionette a couple of days ago. Any help would be appreciated. Symbols.vwx

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...