Jump to content
Sign in to follow this  
Petri Sakkinen

Open GL fails in a large file

Recommended Posts

I have a rather large file (according to Artlantis, 117,000 objects). It renders OK in Artlantis and RW, but with Open GL, parts of if (floors) are rendered incorrectly, with the sides (edges) invisible (transparent) in a very strange way.

Does anyone else have similar experiences or is this 'just' a corrupted file?

VW 9.5.0 at 400,000KMac OS 9.2.2G4 / 800MHz / 768MBno other programs running and VW says there is over 300,000K free memory

Share this post


Link to post

Reduced the overall size of the model (simplified DTM) and now Open GL rendering fails even more seriously: buildings are at incorrect levels (sunken in the ground).

The file is now only 6MB, 12,600 objects. In Artlantis, I have a tad over 60,000 objects.

The other change was that I exploded the DTM symbol to individual polygons to apply different colours to certain parts.

This is getting on my nerves: tomorrow I should run a design workshop, with real-time walk-throughs & fly-bys shown with a data projector.

Share this post


Link to post
Guest

Open GL rendering utilizes QuickTime at some point in the rendering process to complete it's task. If you have too much memory allocated to VW, it could be that there is not ample memory for the system and QuickTime to use for the rendering - which could in turn result in a crash or some objects not rendering.

If you would like one of us here to take a look at the file, we can run a test on it here and see if we can get the same thing to happen when redering here in Open GL.

[ 03-28-2002: Message edited by: Katie ]

Share this post


Link to post

I have something like 300MB as the 'largest unused block' when running VW only (normal case for tasks like this) so I don't think memory is the problem.

Anyway, as I continued my experimentations, I found out that when I link the DTM layer to individual 'model data' layers, Open GL rendering works. Logistically, this is not workable as I have 'model data' in six WGR files and I really need to have a separate 'composite model' which I can use to generate 3D views of the entire study area.

In the other case (small file, video projector) I only had about 200MB free memory as I have only (?) 640MB RAM in the PowerBook.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...