Jump to content

How do I drag selected objects without the selection shifting to "top" object?


Recommended Posts

This is something that has confounded me since I started VW.

 

Say I have a stack of objects - let's say 6 - that overlap.

I've selected 5 of them (but NOT the top object)

If I try and drag those objects VW ignores my selection and auto selects the top object.

 

 

I seem to run into this often and the only way I've found is to send the offending top object to the back, drag the other object, reselect the offending object, send it back to the front where it belongs.

 

What am I missing?

 

 

Video of it happening just now...

 

 

Link to comment

That looks like VW's behavior many versions ago.

AFAIK that was fixed at one point.

At least it worked for me.

VW then prioritized the selected object to drag vs re-selecting the mous upper

object like in your video.

 

Did not test in latest VW release though. Did that get corrupt again ?

 

Or do you have any strange settings in Top Bar for the Select/Drag Tool ?

I ask as your cursor indicator looks strange to me.

For me before dragging, I wait for a diagonal cross from to double arrows icon

which shows I can drag vs the resize single double arrow.

 

But you have that strange plus-like icon.

Edited by zoomer
Link to comment
9 minutes ago, zoomer said:

But you have that strange plus-like icon.

 

 

Hmm.  I've always had the strange plus like cursor to drag as opposed to the diagonal arrow to scale.

 

 

Here is my selection tool settings:

 

image.png.235c992d0bf6b213870863d05133ea16.png

 

...does that look different from yours?

 

 

I would really like to have selected objects drag by default.

 

Link to comment
16 minutes ago, zoomer said:

That looks like VW's behavior many versions ago.

AFAIK that was fixed at one point.

At least it worked for me.

VW then prioritized the selected object to drag vs re-selecting the mous upper

object like in your video.

 

I think this was only changed for coincident linework / edges, not for when the fill of another object is completely in front of the object you're trying to select like in the recording. In fact what I see in the recording matches my expectations of behavior in current builds.

 

@hollister design Studio  – I think the best thing to do in this scenario is to either A) hold to the "B" key to activate X-ray mode before dragging, meaning the cursor will ignore the white fill of the offending object, or B) use the Move By Points tool, first mode, in order to move the geometry since this tool won't change the selection at all.

  • Like 3
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...