Jump to content

Truss with mysterious red crosses

Recommended Posts

I'm at the beginning phase of working on a rendering and for some reason I'm seeing red crosses at the ends of the truss.  Truss in question is Prolyte X30V.  I've turned off the truss-cross/insert points/label/magnet and simplified classes and that doesn't have an effect on the crosses.  I've also tried editing both the 2d and 3d geometry and even with every class turned on those red crosses are not visible in editing mode.


Furthermore the rendering style doesn't seem to matter, they show up all styles.


As anyone seen this before and figured out a way to remove the crosses?


VWX 2022 SP3.1



Link to comment

Thanks Pat.  I believe my truss crosses are different than what that thread is referring to.   The truss crosses in that thread are automatically generated by BW, typically when one truss is laid on top of another (for example).  I’m well versed in classing those and turning them off.  The truss crosses I’m referring to are at the ends of the truss and ever present.  They seem to be hard coded.

Link to comment
  • Vectorworks, Inc Employee

The red crosses are the  auto-connect attachment points of the truss, not truss crosses (the truss cross issue is being addressed in 2023) and are automatically created based on the truss objects BrxTrussItemRecord (accessed by the Customize Truss Symbol Data command in the right click context menu, not from the data tab of the OIP)
Normally they should only be visible in Wire-frame or shaded polygon modes and not in Shaded or Rendered view modes. They will also  display if the truss has been converted to a hanging position but this should only happen when the position is selected.

This was an issue in 2021 and older versions of the software and as far as I know was fixed for 2022, it works correctly for me (I can only get the crosses to display if I'm in Wire-frame or shaded polygon modes), but I use a win 10 PC not a mac which may be part of the issue.
Otherwise from your screen shot it looks like you may be using a customized truss library, since the trusses are black.

If it is a custom library do you get the same issue using the default library version of the trusses?

When was the custom library created?


  • Like 1
Link to comment

Hello Jesse, the trusses are the Prolyte x30v from the straight truss library.  I’ve just edited the 3D geometry to use class attributes and filled a dark gray.  No custom trusses and these are not hanging positions.  And just to confirm, these auto-connect attachment points show up in every render mode I’ve tried, including hidden line etc.


I’m on Mac OSX

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...