Jump to content
  • 1

VW 2022 SP3.1 macOS Monterey hangs when importing a PDF



Ever since I upgraded to SP5 (curiously reflected as "SP3.1" when I boot VW) I can't import more than one PDF. A second PDF causes a death-spiral beachball and requires a force quit. Coincidental to this problem is the inability to close a VW file by clicking the red circle at the top, left side the window. This, of course, is added to the problem of not being able to switch between multiple open files by clicking on the window tab. It only switches via the "Window" pull down menu. These and other bugs are annoying, but not totally fatal, but this PDF problem is BIG. I often import PDFs and VW's failure to do this anymore is a big pain. I have to change a file to some bitmap format to bring it in and you can't snap to a JPEG. I need vector file import. Is anyone else seeing this and, if so, have any idea how to fix it?



Link to comment

9 answers to this question

Recommended Posts

  • 0

I am still on Catalina, but I just tried and imported 5 PDFs and a PNG and had no crash. I have not heard of anyone else having VW crashes on PDF imports.


1.  3.1 is the most recent VW so you should be good there.

2. Are you running the most current release of Monterey? Go to System Preferences and see if there are any Software Updates available.

3. Are you by any chance running a computer that is using 3rd party, non-Apple memory?  You seem to have so many odd occurrences that it seems like it could be a bad memory location.

The following steps are the normal troubleshooting steps.

4. Go to Vectorworks Preferences and click the Reset button. This will reset all the preferences but keep your serial number.

5. Try and move your user folder and restart VW so a new one is created.

6. Run the Vectorworks 2022 Updater app (from Applications:Vectorworks) and choose Repair from the Advanced Options at the right side of the window.

7. Reinstall VW.

8. Reinstall OS and VW.



Link to comment
  • 0

Thanks, I'll try those things. I'm using a MacBook Pro which does not have upgradable memory, so it's all Apple. Anyway, bad RAM would probably exhibit global, OS-level glitches and I've not seen anything like that. Thank you for the tips!



Link to comment
  • 0

When you start your computer do you always launch programs in the same order (I do as I have a bunch set to launch on startup)? That could put things in the same relative memory locations.


Here is a link to the Apple hardware test:  https://support.apple.com/en-us/HT202731


In 2019 Crucial (my go to for good memory) recommended an app called Rember for checking memory. But it has not been updated since 2010. I don't know if it will run on Apple Silicon or not.


Not likely it is a memory problem, but based on some of the things you are seeing that don't seem to effect others people, it is probably worth checking.

Link to comment
  • 0

Thanks, Pat, but I have no idea what "IMNSHO" means.

Right now I have imported a 35MB PDF into a VW file. In 1989 that would have been a huge file, nearly the size of many hard drives. Today, however, that is tiny. Once imported, however, my MBP 16" i9 with 32GB of RAM slowed to a crawl. I'm getting beachball times of 15 to 20 seconds just dimensioning a view port of this PDF. I find that inexcusable in modern software. With all due respect, it has nothing to do with with the possible causes you mentioned. At least it shouldn't, not in 2022. In my experience, it probably has to do with either 1.) sloppy coding in the OS or 2.) sloppy coding in the software. File handling is so important especially when referencing files as VW does it really needs to have a lot of attention put to it. As with just about everything, it is the unsexy things that count the most. I really like VW and I believe, on balance, it works much better than other CAD/rendering apps I've used. I love being able to build one CAD model and use it from concept, schematic, final design and on to CDs. But this PDF thing is really a killer. I'd love to know why it happens, how to get around it, and/or when it will be fixed. Now, about texture mapping...:-)



Link to comment
  • 0

"In My Not So Humble Opinion". 😉😂


PDFs can be a problem, especially vector PDFs if they contain an inordinately large number of lines.  I have seen PDFs that I could replicate in VW using less than 100 objects that due to whatever system they came from resulted in over 1 million line segments once imported into VW.


If you don't need to be able to snap to the PDF, consider pre-processing it and convert it to a Raster format. Then VW will deal with it as a single object instead of a large number of lines and points and potential snap locations.


And consider submitting the PDF to tech support with a note that it does not import and work well in VW.  Unless they see the actual files that are causing problems they have no way of figuring out what needs to be fixed.

Link to comment
  • 0

@MHBrown I was curious about this because of other problems I've experienced which I feel are related to memory problems.


I located some "sample" large PDF files by googling, which others could try with if they wanted to replicate.


An approx 105MB file from here:   https://cartographicperspectives.org/index.php/journal/article/view/cp43-complete-issue/pdf


An approx 26MB file from here:    https://research.nhm.org/pdfs/10840/10840.pdf


I am on Monterey 12.1 and tried on VW2022 SP3.1 as follows:


1. Open blank file in vectorworks

2. Import the 105MB pdf (selecting "all pages") directly into the design layer

3. The PDF imports quite slowly, with some beachball moments, but does eventually all appear. and VW appears basically functional

4. I note that this brings VW's memory usage (in apple activity monitor) up to 6.8GB which seems a little disproportionate to the size of the PDF?

5. Import the 26MB pdf in the same way

6. Also imports slowly, with some beachballs and hangs, but eventually all appears. VW basically functional although zooming/panning might now be a little sluggish

7. Memory usage has now gone up to 9.9GB


Then I tried importing the same PDfs into some "real files" with mixed results, and some investigation led me to suspect the scale of the design layer might be significant.


When I open a blank file in VW, the default design layer's scale is at 1:50. But if I open a new blank file and change the scale to 1:1, then repeat steps 2 to 7 above... the imports are faster, and the respective memory usages are 2.5GB and 2.9GB (ie significantly less).


If I do the same but with the design layer scale set to 1:5000, the experience is similar to the first experiment but memeory usages come in at about 6.9GB and 10.2GB. VW seems to remain functional, but I haven't tried to do anything further with the file.


Don't know if that offers any clues.

Link to comment
  • 0
1 hour ago, line-weight said:

I am on Monterey 12.1 and tried on VW2022 SP3.1 as follows:



I am already on 12.5 Public Beta.

I think current is 12.4.


(Not that I felt that any new official point release would have been any better

than the first Public Beta. It is just that the same bugs go and reappear

randomly with every new update)


Just to say ....

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...