Jump to content

Cable following several consecutive cable paths - VW crashing

Recommended Posts

I've been playing around with the cable tool today to calculate cable run lengths etc. and found VW crashing very often, when I was ending a cable run that utilised several cable paths consecutively. Loving the tool, but not the crashing part!


I'm not sure if having several cable paths that are consecutive is the best way to use the tool, but doing this in a new file worked fine with no issues, so I suspect there is a corrupt part of my existing file, which was made years ago and has come up through several versions of VW. However, all the cable paths and cable I used I put in today myself, not using any parts imported into the file from anywhere else.


I've attached a file that contains just the cable paths that I copied out of my working file, which still shows the crashing behaviour. 

I have done the following, which always results in VW crashing:

Start a cable run (32/1 type) where I have placed text on stage left, run round to where the cable paths join USC, attach to main cable route that goes over the roof and drops down behind the seating rake to racks that are underneath it. When I click to complete the cable, crashes.


Start a cable (socapex) at the racks under the seating rake, drop onto the cable path that drops from the roof onto the lighting truss (text indicating this location), end it nearby. Completing cable crashes the program.


Sometimes, running a cable using only one cable path crashes VW, but usually it is fine. For example, there is a 63/3 that starts SR and follows the single path all the way to the racks and that didn't cause an issue.  


Not sure whether this is a bug, or whether theres just some problematic item in my file that is breaking things. 


Also, I'm finding that the cable wont follow the truss properly, but I think I have read on other posts relating to the cable path tool that often truss created in older versions of VW doesn't behave very well with the cable path tool.


Would appreciate if anyone has any experience of this and how they may have solved it.




VW 22 SP3 (636848)

HP Envy Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz   2.90 GHz


Windows 10 Home, 21H2

Cable path tool old.vwx

Link to comment
  • Vectorworks, Inc Employee

Hi Jake


I had a play with your file and was able to verify that there is a problem.

I'm not sure what is causing the issue though, it does seem to be specific to these specific cable path objects, as if I recreate the cable paths in a new clean file I don't get the crash to desktop.

Please contact the UK tech support team to have a deeper look at your file.


12 hours ago, Jake124 said:

Also, I'm finding that the cable wont follow the truss properly, but I think I have read on other posts relating to the cable path tool that often truss created in older versions of VW doesn't behave very well with the cable path tool.

The main potential issues when tying to get cables to follow trusses automatically are,

  •  truss symbols from earlier versions of Spotlight that do not have the new magnets in them. The magnets define the auto-connect behavior which is also used for drawing cables.
  • incorrectly created or corrupted truss symbols, if the truss hasn't been correctly set up to begin with or has somehow lost the data needed by auto-connect then cable will not follow the truss line automatically.
  • The wrong mode of the cable tool is used, if schematic distributor mode is used then the cable will not follow a truss line automatically
  • The target object is not part of the same truss system, it could be that it isn't correctly connected to the truss, or that the trusses are not part of the same system for example connected by a grapple (which is not supported by Braceworks), truss cross or a drop. Easiest way to check is to use the select system objects button in the truss properties
  • the user has not connected the cable to the truss (by clicking on the truss) after exiting the cable path


Link to comment
  • Vectorworks, Inc Employee

Hi Jake,


I have downloaded the file and created many cables as per your instruction and I cannot replicate the crash.


1. What graphics card do you have?


There may be a number of things causing the issue, you mentioned an old file and whilst you have new objects it might be worth updating the plugins in the file, tools - utilities - update plugin objects.


Also are you running 2022 SP3? We fixed a bunch of stuff with cable tools in this service pack.


When you installed 2022 did you instal into a new folder or did you overwrite/merge? It might be worth repairing your user folder which is an advanced option inside the Vectorworks Updater program/application which you will find inside your program files in the Vectorworks folder.


If this doesn't resolve it please contact tech support.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...