Jump to content
  • 0

Wrong values in Num Channels


Question

I use custom symbols and custom Light Info records for my drawings. When I bring in some fixtures, the num channels field is different than how I've set it up in the record. The field is also greyed out so I can't change it in the OIP. It happens every time with certain symbols and never with the rest. I've verified that the field is correctly set in all the places I know to look. 

 

I can fix it by Spotlight>Reports>Lighting Symbol Maintenance>"Update all lighting devices." Problem is when I do that, it also erases the "Channel" field of all my lights. If I've forgotten to check before I start numbering, it creates a lot of double work for me.

 

Any ideas?

 

1882134197_ScreenShot2022-05-09at4_25_54PM.thumb.png.d16f56bb5a0e72a8c0282f3fd3440ac4.png2120680108_ScreenShot2022-05-09at4_25_19PM.thumb.png.63049366320cde1296dec3ad8c96c404.png

Link to comment

5 answers to this question

Recommended Posts

  • 0
  • Vectorworks, Inc Employee

In order to stay consistent with export to visualizers and consoles the Number of Channels is determined in this order, GDTF Mode, Fixture Mode then the Light Info Record.
When the Number of Channels is determined by the GDTF Mode or the Fixture Mode the Number of Channels field will be disabled.
If you want to manually set the number of fields you will need to set the GDTF Mode and Fixture Mode to None.

Link to comment
  • 0

I haven't assigned GDTF modes to anything. The field is set to none. Also, as you can see in this picture, even fixture mode has no effect.

 

I store my custom symbols in a separate file that is under the "Favorites" tab and then import the symbol definition into my working file. I just built a symbol from scratch. When I place the symbol in space in the symbol file, the Num Channels field is available to edit (Screen Shot 2). When I open a new file and drop it in, I have the same issue. 

 

When I start a new file, I use a template file that I've created. Could there be some deep buried setting that is causing the issue. I've also attached that file. 

Screen Shot 2022-05-10 at 10.18.00 AM.png

Screen Shot 2.png

LD-CDS-V22.0.vwx

Link to comment
  • 0
  • Vectorworks, Inc Employee

In your template file Open Spotlight Preferences > Parameters and select Settings: <Spotlight> Click OK and see if that resolves your issue.

The Fixture Mode parameter is hidden in your template file so the made may be getting set automatically but you can't see it.

I've also seen issues where over time adding, removing or reordering parameters causes some controls to be improperly disabled till the default OIP is restored.

Link to comment
  • 0

It does...It's strange because I do not have this issue with every symbol. I'm assuming at this point because they don't have a fixture mode attached to them.

 

Is there a way to default the Fixture Mode parameter to "None" through an attached record or similar? Maybe there should be an option that allow a user to turn off GDTF globally in a drawing so I can set my template file with that. 

 

I appreciate your help.

 

Link to comment
  • 0
  • Vectorworks, Inc Employee

Fixture Mode is automatically looked up by using the Instrument Type supplied by the Light Info record. It will automatically do a name match.
If there is no match found the Fixture Mode will be set to None.
The GDTF mode is set to None unless it it set manually in the Tool Bar of the lighting Device or the OIP.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...