Jump to content

Tip: Fix for Redshift not using GPU


Recommended Posts

As discussed yesterday at the virtual open house I wasn't able to get Redshift using the RTX3070 GPU of our new notebooks. I managed to fix it by:


1. Installing the 'STUDIO DRIVER' instead of the 'GAME READY DRIVER' 


2. Enabling GPU acceleration with windows 10:



3. Add vectorworks.exe and cineware.exe in nvidia configurationpanel to use the nvidia GPU






Hope it helps others

  • Like 3
Link to comment
  • 10 months later...
  • 2 months later...
  • 2 months later...

This might be reviving a bit of an old thread at this point, when running a Redshift render with Denoise as on is it expected that the denoise phase should run on the CPU?  Right now that phase runs on the CPU for me, not the GPU.  I am not seeing the Cinema 4d process in my process list, but in the Nvidia settings VW lists as Maxon Cinema 4d, so I suspect everything is configured correctly there.

Link to comment

I am going to put this here in case others are looking in the future.  On my Windows 11 machine, it looks like Windows has taken over assigning programs to the graphics card, so I had to go in to System > Display Settings > Graphics, and in there list Vectorworks to only use the GPU via the windows dialogue box.  Things seem to be behaving better now.


Making those selections/decisions inside the Nvidia control panel were having no effect.

Edited by Anthony Neary
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...