Jump to content

VW12 No More Workgroup referencing of SYMBOLS?


Recommended Posts

In VW11.5 One could workgroup reference a file and check no layers. It would then reference all the symbols of that file without creating any referenced layer.

Doesn't this work anymore with VW12?

I've tried but no symbols appear. If I try to put a symbol from the resource browser (after having reference the file) the symbols becomes just imported and are not in Italics and do not update.

I've tried to reference the file both from the workgroup reference dialog box or from the resource browser. It does reference my file without any layer, but I cannot acces the symbols???

The only way I have found is to create a layer call e.g. LIBwindows for windows library and to put an instance of the symbol there and then to reference that layer of the file??? Is this normal? its ok for use, but I get all those additional not useful layers on top of an already very long list...

Link to comment
  • Vectorworks, Inc Employee


I'm not sure exactly what you mean. When you said that you tried but no symbols appeared, do you mean that you expected that all the symbols would be referenced by creating a reference to the file and not selecting any layers? That did not happen in 11.5 either.

You said that after referencing the file, if you get a symbol form the resource browser, the symbol is just imported and the name isn't in italics. I tried doing this several different ways. It always referenced the symbol. The name was in italics. How exactly did you get the symbol?

Link to comment

Hi Bruce,

I've just redone it in both VW11.5 and VW12 to be sure before answering you :

In VW11.5 :

1. I go in >Organize>Workgroup reference.

2. I reference a file, say resources.mcd without selecting any layer

3. I browse resources.mcd, and when I import a symbol (ie windows). It is imported in my current file and it is in italics. It updates when I update the resources.mcd file.

In VW12:

1. I go in >Tools>Workgroup reference

2. I reference the same file (first converted to vw12) also without selecting any layer.

3. I browser the file and select a symbol same way as above and I import it. It goes in my file but is NOT in italic and does NOT update.

4. If I try to reference the symbol directly from the browser I've got the same result. and if I redo it just to be sure I've done it correctly it says tat the file is already referenced... No italics, no updates???

Link to comment

Hi Bruce,

Did you have a chance to check my way of doing?

Meantime, i've done some checking on my side. I experiment something htat you might find quite interesting : I did it on several computers under different configuration the result was the same :

It DOES reference a symbol from another file if that file is on the local Harddrive.

It DOES NOT reference that symbol if that very same file is saved on a HDD of the server on the network...

Isn't this special?

what do you think?

Link to comment
  • Vectorworks, Inc Employee


Thank you very much for your assistance with this problem. When I tried to duplicate what you reported, I had my source file on the local harddrive. When I moved it to a network drive, I saw the problem you reported.

With further checking, I found that this is only a problem on Windows. Also I believe it is only a problem if you have mapped network drives. For instance, I have an Engineers volume that I have mapped to be drive E: on my Windows machine. When opening a source file from the Engineers volume on the resource browser (either doing a Browse or an Add to Favorites), if I navigate to it by clicking on the E: drive under My Computer, I have the problem. However if I navigate to it by going through My Network Places, then I don't have the problem. So you can work around the problem by not using network volume mappings for now. This will be fixed for a future version of VW.

Link to comment
  • 3 months later...

This seems to be related to a problem we're having with 12.0.1 on Mac OS X.

We have a drawing list in a worksheet, in its own file. We want to reference the worksheet into a plan file (_not_ import).

Open the plan file. Navigate to the worksheet file. Right-click the worksheet and we are offered the choice of "reference" or "import." Click "reference."

The trouble is "reference" seems to work the same as "import," ie. VW copies the worksheet into the plan file, so it misses updates to the worksheet file. It doesn't seem to matter if it's on the network or local.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...