Jump to content
  • 0

Site Model Looks Wrong



13 answers to this question

Recommended Posts

  • 0

Because of the intermittent and graphical nature of these symptoms, I suggest you check your file for 'far out objects' using the guide linked below. (Sorry, it's out of date. Just ignore specifics about the 'Unified View'). If you're certain you don't have far out objects in the file, then try updating your graphics card driver - info also linked below. 




  • Like 1
Link to comment
  • 0

Thanks @PVA - Jim driver was indeed out of date.  NVIDIA also offers two types of drivers for the graphics card one for gaming one for studio applications.  I was out of date by two years.  Reinstalled the driver and centered on origin.  Also had a windows update pending.  Did all three things and it appears VW is now in turbo mode.  Booting quickly and seems way more responsive.  VW is still dogging in this file.  This is what I'm seeing now.  I separated the site model from the rest of the drawing.  It seems as if the rest of the drawing is working pretty well.  The site model is lagging when I switch from 3d no display to 3d proposed  3d mesh colored.  I see some site modifier conflicts that are overlapping pads... Not sure if that could be contributing.  I have submitted to tech support but I'm hoping to get a solution sooner so I can keep going on this one.

Screenshot (103).png

Screenshot (104).png

Screenshot (105).png

Link to comment
  • 0

Just a couple of quick comments shooting from the hip; If the lag/load issues relate to the site model only then: 

  • Check how much geometry (number of vertices) are present in the data that the site model was created from. You could try reducing the number of vertices using [applicable menu commands or techniques]. 
  • Try copy/pasting the site model into a new blank document. You could use 'paste in place' to preserve location but using normal paste might be more sound, then close the original file and see how it performs in the new one. Copy/Paste [into a new file] can fix corrupt data, but I suspect the above is likely more relevant. 
  • Like 1
Link to comment
  • 0

The topo was created by VW from spot elevations I entered.  I ungrouped the site model and it doesn't appear to show a ton of vertices but does have a ton of site modifier conflicts.  I submitted to tech support 5 days ago.  I separated the site model from the hardscape and building layer and still get crashing on both.   I experience this on a regular basis in other drawings too.  I don't know if I have an issue with my system...is there a way to scan to see if the system is optimized for VW?  The unfortunate part is I spend as much time troubleshooting as I do designing.  See the attached file if you wish to take a look.  I also tried to work with it in 2021 with the same result.  BTW is 59 mb a particularly large file?


I did just notice that while I had my files backing up to one location as VW went though its crashes it decided to change the backup location to back up to original location from the dedicated folder I set up.  Now I have back up copies in various folders across the drive.  I also have a ton of backups could that be an underlying issue.  I'd like to get the final drafts of what I completed, put it in the clients folder and delete all the other backups.  Is that considered good practice or is there a better way to store final drawing docs.  I remember a thread about excessive backups and crashing.

Screenshot (111).png

Parks 2-21.vwx

Link to comment
  • 0
9 hours ago, Landartma said:

I experience this on a regular basis in other drawings too.


Seeing as issues occur with other files, either they are all derived from a corrupt template/source file, or your Vectorworks User Folder data, the current installation of Vectorworks or your computer's capability or its soundness or setup are questionable. Luckily the most likely cause is among the easiest to fix: Run through the Resetting Vectorworks Preferences process. (Read and abide all instructions carefully!) 


9 hours ago, Landartma said:

I don't know if I have an issue with my system...is there a way to scan to see if the system is optimized for VW?


No, but here are some things you can manually check or ensure. Note however, that in your case I don't think you should spend your time with this given the stage you're at (see next section). I'm putting this info here for other users experiencing various issues: 

  • Your computer should be suitably powerful to meet the demands your files invoke. See the profile levels described in Vectorworks System Requirements
  • Ensure the operating system is compatible and is up-to-date. 
  • Ensure Vectorworks is compatible with your operating system and is up-to-date. 
  • Windows users need to check that their graphics card drivers are no older than six months and if issues are of a graphical nature, perform a 'clean' installation of the most recent graphics card driver available. 
  • Windows users with both an integrated and dedicated graphics card must ensure Vectorworks is 'assigned' to use the dedicate graphics card. See article, 'Multiple Display Adaptors / Graphics Cards.


9 hours ago, Landartma said:

The unfortunate part is I spend as much time troubleshooting as I do designing. 


This is a red flag that corrupt data is consistently at-play. It's not normal and does not need to be tolerated. If Resetting Vectorworks Preferences doesn't restore normal functionality, do an acid test to rule in/out your files. Acid Test: This diagnostic process is especially reliable if you have just Reset Vectorworks Preferences beforehand and find the issue occurs in a [default] 'new blank document.': 

  1. Go: File > New… > 'Create blank document' 
  2. Recreate the conditions/scenario/process concerned that normally incur issues, without using any data from your existing Vectorworks files. 
    • If the issue does not occur, the source is probably your documents. 
    • If the issue occurs, we know the source is not your document/s. At this point a clean installation of Vectorworks might be warranted, but these findings should be referred to Vectorworks Technical Support because depending on [various factors] they may check if it's a software bug, or software conflict etc. 

In summary: 

  1. Do Resetting Vectorworks Preferences. Check if issues persist. 
  2. If issues persist:
    1. Go through the above checklist. 
    2. Do the acid test. 
Link to comment
  • 0

Oh man @Jeremy Best thanks a ton for the help.  I'm 90% sure my system is up to the task as it is spec'd for high end VW although to the lower end.  The steps I took so far seem to have sped up the system.  I'm thinking I may just do a clean reinstall and clean driver install of my Video card.  My issues tend to come when I get into the 3d and more complex (for what I do).  My next question is does VW have a definitive guide on how not only to spec a machine but to set it up with all the correct settings?  It would be great if VW had an optimizer/analyzer app that could do that work.

Link to comment
  • 0
On 2/24/2022 at 10:44 AM, Landartma said:

I'm 90% sure my system is up to the task


The spec's shown in your signature should be very adequate for the file you've posted - as are mine - but when I turn on the 3D display of your site model, my CPU becomes fairly active and processes for a long time, but what is more notable, is the increase in memory consumption. This usually signifies a large quantity of data/geometry is [now] present/being processed and retained for display. This is further evidenced by how laggy my GeForce RTX 3080 becomes in these conditions. Also, despite being set to 'Shaded' everything else with textures and solid surfaces render fine, but your site model remains wireframe. At this stage given the above performance, coupled with the permanent wireframe appearance when rendered in 'Shaded' mode, - it looks like either: 

  • The site modifiers are mal-forming the site model. 
  • The site model itself is malformed. 
  • The data it was created from problematic (in one way or another). 
  • The site model is just plain ol' corrupt and needs to be recreated. 

Since writing the above I believe I've confirmed the latter - that the current site model object is corrupt. Because: 

  1. I copied the 3D Elevation markers from the source data of your original site model. 
  2. Used 'Paste in Place' to put them in another new blank document and used them to recreate the site model. 
  3. Used 'Paste in Place' to copy over just the [house] pad and the perimeter slope/grade modifiers. 
  4. Updated the site model to check the result. - Looks good and this file remains responsive. 
  5. Used 'Paste in Place' to copy over all remaining modifiers (7? retaining wall modifiers). 
  6. Updated the site model. 

The result is that it looks to have the same amount of vertices/geometry as the original, yet it is free from issues and remains responsive. 




Copy/pasting objects sometimes corrects corruptions they may have, however when I tried copy/pasting your entire site model it seemed like it was taking longer than rebuilding did so have given up on completing that test. - EDIT/Update: The copy/paste process took AGES but finally completed, but it demonstrated the same problems as the original. So the solution remains to rebuild the site model using existing data. 

Try the above process and rebuild your site model using existing data. It may not be necessary to copy it to a Create blank document, but it's easier/less cluttered and more sound to do it that way. 

  • Like 1
Link to comment
  • 0

99 Conflicts, but the graphics card aint one....


For what it's worth, I have a different opinion on what is causing this problem with site model.

The data is not corrupt, the computer is not guilty... the modeling method is to blame.

Big issues...

Using too many design layers with objects containing site modifiers scattered across them.  Then, setting up the site model to "listen to" too many competing design layers and objects.  When you have 99+ site modifier conflicts and competing aligned or sloped slabs Vectorworks is sitting there thinking "what the heck am I supposed to do with this hot mess?" 🙂



Moving the objects to a single hardscape design layer, setting up the site model to listen to that one only yields one level of improvement.

Fixing the objects so the modifiers are not fighting with each other clears the problems completely.


As we discussed on the phone, graphics card and other computer problems are certainly an issue that must be resolved.  However, this site model you posted here on the forum behaves badly on both of my perfectly running computers.  Once I fixed the model issues, it flies equally well on a 2015 MBP with 16GB RAM/2GB Vram and a Imac with 64GB RAM/8GB Vram.


When you enter the world of site modeling with aligned slabs and modifiers, it's easy to get lost and create problems that are hard to see without experience.   The secret is proper organization, careful use of objects/modifiers, efficient/correct configuration of objects, and using consistent/repeatable methodologies.  Staying one release behind on Vectorworks and joining the apple cult has its advantages too.  Things will get easier... site modeling voodoo just takes a bit of practice.

  • Like 1
Link to comment
  • 0

I'm not sure what's a harder pill to swallow adopting Voodoo or joining the Apple Cult😯.   I will proceed to assure the machine is running and configured properly.   My question is how to access the original site data I want to try to replicate what you did @Jeremy Best.  Did you recover my original stake objects?  So if I'm correct you simply recreated my original site model and just pasted it overtop of my site modifiers?  I'm working on another one and I'd like to look at my original source data.

  • Like 1
Link to comment
  • 0

Here's the update.  The system is humming along nicely but needed a few adjustments.  We went through the graphics card settings...See attached.  We went through the file and it is the site model either corrupt or sloppy work on my part.  We also identified that VW back up was running off a standard disc drive and was moved to the SSD drive as the standard drive is much slower.  The task manager never showed VW stopping/crashing just working really hard when I attempted to work with the site model.   I think its safe to say my system is good and VW is running as it should as well.  I'd like to restore my preferences that's Tools, Preferences, User Folders, select C/Users/Owner/App Data/Roaming/Nemetschek/20xx/Libraries/choose folder? 

3d app decides.png

gsettings top.png

Gsettings 2-3.png

gsettings bottom.png

psettings top.png

psettings 2-3.png

psettings bottom.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...