Jump to content
  • 0

VW 2022 crashing randomly - Encountered an improper


luiza_finger

Question

Hello!
Within VW 2022 I am having this annoying error showing up and crashing VW. It happens both before and after SP.
Running on Windows 10 64. VW 2022 updated with  SP - Build 614805.

It happens very randomly... Sometimes it just crashes, but usuaIly this message appears before it happens.
There is not a particular scenario that I could figure out, but it seems to be related to Organization Tab. At least it seems to happen more often while I have it active.
Perhaps it could be related to the file itself. If so, I could post the file here in case it can help us figure out what is going on, as it gets really disturbing sometimes.

Thanks in advance.
Luiza.

0101.PNG

  • Like 1
Link to comment

7 answers to this question

Recommended Posts

  • 0
  • Vectorworks, Inc Employee

I don't find these fragments anywhere when I search our code and strings, so the next questions are 1) which distributor did this come from, since they can add plugins or change strings, and 2) what other extra plugins might be present?

 

Thanks, Rick

Link to comment
  • 0

I've also been experiencing this same issue since v2022 came out. I am also seeing "A required resource was unavailable".

It occurs when I go to edit some models I've created and where I've used the Add Solids command to build that structure. 

Not sure if a file size being so large is a factor as the one I'm currently working on that is crashing with this issue is just over 199,300kb in size.

Link to comment
  • 0

Sorry for the late reply. After SP2 things seems to be fixed for me.
I do not have any third party plugins.
 

Only thing I had was a few plugins to restore saved views with a simple command like such.

 

VRestore('SV_GroundLevel');

 

They worked fine. Maybe I have switched names on the saved views and the plugin did not found the proper name.
The thing is that it seemed quite random. Maybe related to some memory cleanup. I really couldnt find the reason behind it.
But for me it was fixed.

 

Thanks.

Link to comment
  • 0

I am also facing similar issue on one of the heavy file which has a file size of 215 mb file size. Whenever I tried to edit something it crashes. Is this a hardware problem or software problem?

Link to comment
  • 0
Posted (edited)

@Parag I do not think this is a hardware problem, as I did not change any hardware and the problems had gone away after Service Pack 2.

I can try opening your file and move things around for you to try to induce the error.

As for plugins, the only third party plugin I have is Import Mosa Pattern

 

Cheers.

Edited by luiza_finger
Mentioning the plugins I have.
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...