Jump to content

Flat DXF to Extruded Model


trashcan

Recommended Posts

I've done this a few times now and I'm looking for best practices / a faster solve. 

 

I got this DXF from the manufacturer:

image.thumb.png.60d35d5c4d9f65b7b0dbaeacce583b79.png

 

I then go through and delete all the junk I don't care about:

image.thumb.png.49a4dee270b6251ccfd5cda7985b1c3e.png

 

I then do that in a fine tuned way trying to delete all the artifact junk from the DXF:

image.thumb.png.12c16dbeacd3a944d3e8dc37b3fd6135.png

 

Then I pick a surface as my base extrude and use the command "Combine Into Surface" and extrude it to the depth that I want:

image.thumb.png.daed1df856ca693f4cdf7c48d9d24436.png

 

Then I rinse and repeat for all the other blocks and then combine at the end. Is there a faster / smarter way to do this? 

 

  • Like 2
Link to comment
15 hours ago, trashcan said:

Then I rinse and repeat for all the other blocks and then combine at the end. Is there a faster / smarter way to do this? 

Unless you manage to get hold of Harry Potter's magic wand then probably not. 🙂

 

You could try to create only the base volume without rounded edges, then put the side surface areas to each respective side and use push/pull to subtract/extrude to the desired depths first and then round all corners where necessary. That is how I would do it in my other CAD program which can recognize enclosed surface boundaries for push/pull but in VW it doesn't work as smoothly so that is one thing where I would like to see VW improve.

  • Like 1
Link to comment

I'm slowly plugging away at this model "in all my free time"

 

And I got stuck:

 

I have two shapes that I need to do a multiple extrude with a depth of .291"

image.thumb.png.7bb5deb03881bb3bf968f455963998b1.png

 

It gets super nasty if I do a multiple extrude:

image.thumb.png.078c241a9595fe9a3602522d0716476e.png

 

If I just the bigger rectangle and do a flat extrude at .291", and then use Deform-->Taper Solid, I get close to what I want but not exactly right:

image.thumb.png.70a3ff86900e3b35f3b1975ab0cbe877.png

Close enough for jazz! But how do I do it right, I wonder? 

 

Link to comment

Another option, depending on the exact shape you need, could be lofting a solid provided you have the proper number of curves etc. It may take a bit more time but overall it could be a bit less cumbersome as well than having to try to get it right with tapered extrudes etc.

  • Like 1
Link to comment

@Pat Stanford coming in hot for the win to help me figure this out. 

 

Changing the direction yielded this result:

image.thumb.png.caefb01eadc5599e1fe162767d25341e.png

 

The smaller polyline object has 13 vertices. The bigger poly line has 51. Hmmm. I recreated the object that had too many vertices and it only had 13. When I did it that way, here were my results:

image.png.ebbe083eca7b4379efb95e7ddc4a3718.png

Whatever method I used to create that bigger poly (don't remember) must be the culprit. 

 

@Art V I have not used loft solid before (or don't remember using it). Do you have any recommendations on where / how to get started? 

Edited by trashcan
Link to comment

Another question.

 

I have created the feet for the projector:

image.thumb.png.7f1e99eeb529c48e01928e8a775189c5.png

 

To create that rounded edge at the bottom of the foot, I created a sphere and used the split tool to use only the portion of the sphere that I needed for the foot. What remained was a Solid Section. Later, I needed to snap something to the bottom of the foot and I wasn't able to get any smart points. Usually when this happens, I switch to wireframe, but oddly that rounded portion doesn't show up! I tried converting the solid section to a generic solid and a nurbs and still had the problem. Any ideas?

image.thumb.png.20a7427878972d03dea8f1425fe5aabe.png

Link to comment

@Pat Stanfordwhat's weird about the solid section thing is that I used that same technique for the lens. So we know it works sometimes

Open GL:

image.thumb.png.c779e182efc6152a96ee69ef052bf535.png

Wireframe:

image.thumb.png.37ded2c7499ae280811296585f880738.png

 

Went back to the foot where that little guy doesn't show in wireframe. Maybe it has something to do with scale? Scaling up it still doesn't show up in wireframe and it isn't clickable. Maybe it has to do with how I made the solid section?

image.thumb.png.7e803d0d5a3867ba148d663c69598135.png

Hmmm nothing weird there. So I redid it:

image.thumb.png.2204248546163797a30fc1aa34878706.png

It worked! Weird...

 

I also tried your sweep method and of course that worked perfectly, too:

image.thumb.png.50fba47ac4efce52308f2357deb57504.png

 

Weird, thanks for the help

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...