Jump to content
  • 0

Vectorworks 2022 Issues



this isn't so much a question as a statement... I finally started using 2022 today, along with 3 other employees in my firm, and we've had multiple crashes and video display issues.  Seems like VW decided to once again release a bug laden product in order to beat the Service Select renewal deadline.  Needless to say I am not very happy about paying for a product prior to its readiness for the market.  It's not going to happen again.


These kind of issues are inexcusable.  I'm not getting paid by VW to bug test their product.  I'm getting paid by clients to deliver documents to them to build.  When I have to waste hours and days trying to optimize a tool to use, I lose money.


I'm going back to 2021 until I see updates being released that hopefully will fix this product.  Then, instead of wasting time on VW bugs, I'll start searching for a tool designed and developed by architects, not by marketing shills.

  • Like 1
Link to comment

16 answers to this question

Recommended Posts

  • 0

2022 isn't supported on Mohave.  https://www.vectorworks.net/sysreq


I've found it helpful in the past when VW has been unstable to boot into safe mode and run VW for a couple hours.  If that works there may be a conflict with some system setting/extension or other software.  


I've been using 2022 for quite a while on my 2019 MBP running Catalina or Big Sur and it's super stable (except when also using Zoom).

Link to comment
  • 0

Same troubles here. I have had several crashes since I upgraded to 2022 a few days ago.

It is so bad that I can no use the workstation at all. It needs to go back to be tested.

For reference, I run this system:

Asus Prime TRX40-Pro S

AMD Ryzen 3960X

64Gb DDR4 3200MHz

ATI Radeon Pro W5700

OS MS W 64bit

Link to comment
  • 0

So far the issues I have run into with 2022 have been sudden crashes based on changes in text, moving nodes in marionette. I have had issues rendering in shaded suddenly becoming jittery when moving around an image.  I have had text half disappear.  I have had imports DWG files cause all 3d objects to turn 100% black and could only be fixed by cut and pasting it back into the file.  


I've had paste in place not function without a restart,

Ghost lights appearing

Title blocks losing geometry when inserted into new files. 


It is pretty buggy.  It also has some great new features for things like connectcad functionality.  I still wish the approach was to make the thing work more consistently rather than be new and shiny.


Additional note, very disappointed there was no Covid support for entertainment designers and fabricators.  Company could have done a heck of a lot better hearing their user base who literally could not work using the program they made... but that is a longer rant.

Link to comment
  • 0

I am running SP1.1.


Text moving is inconsistent, I think it is unrelated to the specific files since there has been no consistency between what causes the issue.


Sure here are a couple example files generally I have found work around solutions because of needed timelines but it is so frustrating when an industry standard is also a troubleshooting session.

It all turned black.vwx Moving Marionette Nodes Crashing.vwx

Link to comment
  • 0

The first file is turning black because there is a KinoFlo Desk-Lite inserted into a wall on the Architecture layer.  Delete that or turn it off in the Vis Palette and everything will stop being black 🙂


I was able to move the marionette object and move nodes inside the object without any problems.


PS.  Cool Marionette.

  • Like 1
Link to comment
  • 0

I was just wondering about that myself.


Perhaps when it got inserted into the wall something was messed up?  The following actions all fix the problem:


1. pulling the fixture out of the wall.

2. deleting the fixture

3. Choosing edit from the OIP and then immediately clicking OK.

4. probably many others.


I've noticed that in 2022 sometimes fixtures take on the symbol of an accessory (usually a c clamp).  I can't tell yet if it's only on fixtures from older version of vw or if there's another cause.  I noticed that only the c clamp was showing and I went to edit the light it was using the c clamp symbol as the symbol for the fixture.  Making it reset fixed it.


I don't yet know if this is a bug or a missunderstanding on my part as to how the new accessories work :-).


I bet nobody thought that a KinoFlo would ever be inserted in a wall, so that may have knocked it for a loop.

Link to comment
  • 0

Not sure.  Part of the struggle was it happened after importing a dwg file into this one.  It became very unclear as to why that triggered the change.


So I didn't even think to look for a hidden light stuck in a wall when multiple people are in the file.

Edited by Dendecko
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...