Jump to content

Aligned Hardscapes only appear in wireframe

Recommended Posts

Thanks for the thought. I've got a texture assigned to the object and the class - the same texture that's applied to the borders which appears just fine. For now, my work-around is to make the borders as wide as possible, but you can see that there is still a sliver of the middle of two of these objects that is still showing in wireframe.



Screen Shot 2021-10-07 at 9.04.04 AM.png

Link to comment

In my case the texture displays correctly but only in the "Border" area, not at all in the "Main Slab" area. I did verify that both the Main Slab and the Border have the texture assigned as well as the class the objects are in. If I turn the border off then then entire object appears only in wireframe. It must be something I'm missing. I don't see anyone else reporting this problem. 



Link to comment

I seem to remember something similar happening to me: a hardscape that suddenly, inexplicably, lost its textures - and displayed in wireframe - and nothing I did could bring them back. It didn't have a border so I have no idea if that would have displayed correctly or not, like your one. I think I either shut down the file + VW + on restarting + reopening it was fine again. Or I abandoned ship + started over in a new file. In my case it was just a file I was trying stuff out in so I wasn't too fussed, just perplexed. It was just one hardscape amongst several. Have you tried anything along the lines of closing/restarting, and/or deleting the offending hardscape + creating it again?

Link to comment

Okay. I got it. The OIP has a place to edit the Main Slab Components. These unstyled slabs each have just one component. I just had to edit the component to give it a fill color. Giving the overall object a fill color in the Attributes Palette did not help.


Thank you for the comments.



Screen Shot 2021-10-07 at 3.13.53 PM.png

Screen Shot 2021-10-07 at 3.18.46 PM.png

  • Like 3
Link to comment

@Ed Wachter  Glad you got it worked.  I horsed around with this in v2022 where the OIP splits the main and border render settings.  


Here's commentary with an image and the files for those interested.


I ran into the same wire frame issue unless two things are in place.

1. Main component is assigned a class and/or a texture in Component Edit. I applied the Site>Hardscape Comp>Main Joint and chose the Materials options to direct the texture.

2. Render tab Part option is set to By Component.


If working with a slab with border, both the components need both conditions.  So in Shape tab open/edit both Main and Border Component settings to apply a class or texture. Also need to do it twice in the Render tab - open the Parts field to choose Main. Set the Mode to By Component. Open Parts again and choose Border, then Mode to By Component.


Another difference in v2022: no discrete Hardscape Aligned Slab object.  Instead, all Hardscape Slabs have option (OIP checkbox) in the Site Modifier area for "Enable aligned surface".  I find this an odd place to put this option, but it works. All this is probably documented, but I only discovered by exploring.


I back saved the v2022 file to v2021 to see how these new conventions are handled in previous versions.  Everything seems to be in order, although a rather simple example file.  Both file versions included here.




Slab render v2022 v2021.vwx Slab render v2022.vwx

  • Like 2
Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...