Jump to content

Class of styled PIO is incorrect and can't be changed


Recommended Posts

  • Member

Dear developers,

 

I have a PIO instance that has object style A. The symbol definition A as well as the style PIO (first member object of symbol A) are in class B. The object style's class is by style (gSDK->SetClassByStyle(obj, true)), but the PIO instance does not have class B but class "None" and the class pull-down menu in the OIP is dimmed.

 

Even worse: I can't even assign the correct class to the PIO instance as ISDK->SetObjectClass(B) blocks the assignment. In function SetObjectClassWithOptionalNotification it is checked if the class is by style and if it is, the function quits so I'm stuck.

 

So this looks like an obvious bug in VW to me. Or is there a workaround or proposed workflow for changing the class of a styled PIO instance?

 

Btw, I can't find a function that gets or sets the class of an object style. Which class is relevant, the class of the symbol definition of the class of its PIO subobject?

 

 

Thanks,

 

Stefan Bender

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...