Jump to content
  • 0

VW2022 "shaded" view flickering hatches & patterns


line-weight

Question

First test run of VW2022 immediately produces some major problems using "shaded" (previously OpenGL) view.

 

These flickering patterns seem to appear on objects that are within a certain distance range of the viewpoint. I have reproduced it in two different files.

 

Turning off "draw edges" in "shaded options" makes it go away.

 

I was already experiencing this in VW2021 (see posts here) but it's even worse in VW2022.

 

This is on an M1 mac mini.

 

 

  • Like 1
Link to comment

12 answers to this question

Recommended Posts

  • 0
13 minutes ago, jblock said:

@line-weightAre there any stray objects located very far from the origin or from the rest of your drawing? If you send me a DM with a copy of the file, I would be glad to take a look.

 

Thanks!

 

I don't think there are stray objects. And it's present in two separate files. I've DM-d you a copy of one of them.

Link to comment
  • 0
4 hours ago, bcd said:

I see someting similar on Windows.  By turning off Shader Options>Draw Edges the issue seems to resolve.

 

Are you viewing in perspective, or orthogonal mode? It seems that it may be an issue when viewing in perspective (which is what I always use when in 3d) but not in orthogonal (which seems to be how a lot of people work but I don't get on with it).

Link to comment
  • 0
4 hours ago, Kazemester said:

I had a similar visual bug that was here forever, but it happened to me when i made huge models (over 2km site models) or the model was far from the origin.

 

In VW2021 it was sometimes happening for me on a quite big model that is about 0.5km x 0.5km in size but in VW2022 it's happening on much smaller models too.

  • Sad 1
Link to comment
  • 0
19 minutes ago, line-weight said:

 

Are you viewing in perspective, or orthogonal mode? It seems that it may be an issue when viewing in perspective (which is what I always use when in 3d) but not in orthogonal (which seems to be how a lot of people work but I don't get on with it).

Yes the issue is persistant in Perspective with Draw Edges turned on in a VW2021 file converted to VW2022, not otherwise.

Link to comment
  • 0
  • Vectorworks, Inc Employee

Hello @bcd in the test file the Crease Angle is set to 1 degree which is why this one shows so many noisy edges.  The default for crease angle is usually 70 degrees.  Set it higher and this one will not show so much noise.

 

FYI Also if you set to 0 degrees you will get pretty much only silhouette edges which might be a look you might like.

 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...