Jump to content
  • 0




I've been using a workaround to address this issue for some time now but the workaround has become less and less reliable.

In the past 5° was a sufficient smoothing angle, but sometimes even 18° is not sufficient to prevent radial lines from appearing at the edge of a flat surface. What is it that we need to do to eliminate these radial lines from appearing in basic 3D objects?

Drawings in which these lines appear continue to cause confusion and errors on the manufacturing side of our business.

VW2021 SP4 (Build 602791) (64-Bit), Win 10 Pro version 21H1 Build 19043.1110, Xeon 2123 16GB RAM, NVIDIA Quadro P2000 5GB



Link to comment

5 answers to this question

Recommended Posts

  • 0

In this instance the plan view is drawing correctly.

Having to draw/redraw elevations in 2d kind of defeats the benefits of purchasing a 3d drawing application.


Interestingly though, by moving the 3d object 10mm or rotating it so that the extrusion's external start plane and its polyline definition plane/origin are not in the same location has made a difference. At least for this object. And if this origin and plane alignment is the trigger it could be why I am seeing this so often. I have a habit of maintaining this alignment where possible so editing is not always a search for where is the defining object.

Link to comment
  • 0

From the VW Help.


Smoothing Angle

Sets the angle to reduce facet lines when the Hidden Line, Dashed Hidden Line, or Final Shaded Polygon mode is selected; if the value is greater than zero, facet lines will be removed between any two faces of an object that are within that angle of each other.


I read this as suggesting that you probably want to be using a big angle value if you don't want facet lines to show.


It also makes me think that your original geometry may have a different vertices than you think making lots more edges that have to be compared to each other and making it more likely that you will have edges that will have an angle that tells VW to draw the facet edge. Make sure your 2D and 3D conversation Resolution (VW Preferences) are set high enough that the angle between the facets is controllable.


I was just playing with a 90° bend that started as as Arc and I converted to Lines with a Low 2D Conversion Resolution showed facet lines at 10° but had them all hidden at 11°.  So the higher the number of facets, the smaller the Smoothing Angle should be able to be.


Unless it is hiding something that you want shown, there is no harm in using a high smoothing angle.

  • Like 1
Link to comment
  • 0

Thanks Pat,

I done the deeper dive into the polyline definition a few times thinking that what you said here might be the case.

I actually redrew the outline in this one because in the first rendition I started with rectangles and used add surface followed by the fillet tool. Which I have seen create a node at the start or end of the radius node. In the second attempt I started with only corner points and then edited the polyline changing the desired one to radial nodes. That at least ensured that there were no extra nodes introduced when I re-rendered the viewports using Hidden Line and Dashed Hidden Line. At which point I had become frustrated and posted here.


After Jim's post got me thinking again, I rotated the object so that one of the sides would be seen in top/plan view. The view rendered correctly. So I reverted and the bad condition returned. So on a hunch I raised the object 10mm above the xy plane upon which I had created the outline for the extrude definition. To my surprise the viewports rendered correctly.


One precondition seems to be that a solids Add or Subtract operation has to have been performed upon the extrude (or steel shape). The Subtract solid being utilized with this 3D bent plate to create the holes.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...