Jump to content

Can't edit incorrect beam angles

Recommended Posts

When I insert symbols, they are inserting with incorrect information in the "Beam Angle 2" and "Field Angle 2" fields.  For example, a Source-4 26 degree inserts with a "Field Angle 1" of 25° and a "Field Angle 2" of 17°.  I can update this instance of course but I would like to be able to fix the symbol itself.  When I go to edit the symbol, though, it only has a single field for "Beam Angle" and a single field for "Field Angle".  The listed degrees are correct but I don't know how to edit "Beam Angle 2"and "Field Angle 2" within the symbol itself.  Any suggestions?


Link to comment
  • Vectorworks, Inc Employee

I wonder if you have and old Light Info Record? The current record has both sets of fields.

Screen Shot 2021-07-30 at 3.54.25 PM.png

Updating the record information on the symbol will only effect newly placed lighting devices.

  • Like 1
Link to comment
  • 4 weeks later...

Hi Kevin,


Yes, that does seem to be the issue, which is strange as I'm using symbols from VW2020.  How do I replace the light info record?  When I try to import a more recent one it says I can't replace the one in the current document.  When I try to import a symbol with a current light info record it only allows me to use the existing record.




Link to comment
  • Vectorworks, Inc Employee

As long as you are not using project sharing you should be able to replace the record format with the updated record.

When you import the record or a symbol with the record aratched you should be prompted with a choice to replace, merge, or keep the existing record.

If you do not see this prompt you may have selected the "Always do" option during a previous session and you may need to reset the option to get the prompt back. Unfortunately, this will reset all "Always do" actions.

Tools > Vectorworks Preferences > Session > Reset Saved Settings... >  Check "Always do the selected action" choices (Uncheck the other option)

Link to comment

Hi Kevin,


Thanks for the suggestion.  Unfortunately it does not give me the option to replace the Light Info Record format when importing, even after I reset the "Always do the Selected Actions" option.  It asks if I want to replace the "parts" record format, but for the Light Info Record it still just gives the options to either use the current format or cancel the import.  (see screenshot) Are there any other ways I might be able to import the Light Info Record?

Screen Shot 2021-09-02 at 1.18.19 PM.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...