Jump to content

Tool Template


Recommended Posts

I have created and am good with event enabled point objects and path objects.  Is anyone willing to share a tool template, or instruction on the difference between an event enabled PIO tool and an event enabled PIO object.  It seems likely that tools are not event enabled, since they do not persist, but a simple example would be good.

 

TIA,

 

Sam

Link to comment

Sam, see this thread: 

 

 

Note, you need a hex editor to enable an event-based tool. The biggest feature of the event enabled tool is customizing the mode bar, as well as handling multiple clicks easier to work with. Many of the limitations are still there though, for example, the code still doesn't run until after the first click.

Link to comment
On 7/25/2021 at 7:55 PM, JBenghiat said:

Note, you need a hex editor to enable an event-based tool. The biggest feature of the event enabled tool is customizing the mode bar, as well as handling multiple clicks easier to work with. Many of the limitations are still there though, for example, the code still doesn't run until after the first click.

 

I just want code to run when an object is duplicated, so my objectID checker will run.  But every time I see one of those event-enabled scripts, my mind turns into spaghetti.

Link to comment
17 hours ago, JBenghiat said:

@SamIWasYour own object or any object?

My plugin objects.  I have custom point-object tools I use for racks, cables, optos, network units, consoles, nodes, etc.  In order to make them import/export with FileMaker Pro (where I have an extensive database I use to track every piece), I have a UUID procedure within the tool which assigns a UUID to the object in one of the fields, and as an object name.  The object name will change automatically If duplicated, and the procedure will check to see if the ID and name match, and generate a new ID if they do not.  But I need the UUID procedure to run again after duplication to make the ID unique to each object.  But it won't run unless I change some data.  

 

HOLY CRAP.  I thought I had tested this before multiple times and it didn't work...but checking "Reset on Move" and "Reset on Rotate" does fix that issue.  Now to go update all my plugins!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...