Jump to content

Double Device Tag


Recommended Posts

When copying devices I frequently get two tags for same device. One of the tags Class is "None", the other is "Sys-Device Tag".

This is a snip from "inside" group Device:

665314222_Screenshot2021-07-15102835.png.2e62dbc363e1dbd52d64d451847d94f8.png

My workflow is:

  • Copy device using Ctrl
  • Edit device using Edit tool
  • Either Save and reopen or when I make cable connections.

I am using Spotlight 2019 and ConnectCAD 2018.

Does anyone has an idea?

 

Link to comment
  • Vectorworks, Inc Employee

Hi @irenao

 

Well first of all I would strongly suggest you upgrade! ConnectCAD 2021 is so much better. And it just keeps on improving.

 

When ConnectCAD 2018 was being tested Spotlight 2019 did not exist. I think you have to at least get onto the same version.

 

Conrad

Link to comment
  • 3 weeks later...

Hi @Conrad Preen,

I like the 2021 version and I would like an upgrade but we have problems working on old files in new version.

There are around 50 files each having 5 to 7 design layers so it would take me a lot of time to do a transfer from 2018 to 2021 version.

Kind regards,

Irena

 

Link to comment

Hi

 

We get this double tag on some of our older devices witch originates from 2018-2020. I recall to have doubling tag problem to be more regular on maybe 2019 version.

image.thumb.png.00652b2d4f4dd76616cfb0e197e00486.png

 

This is from 2021 version where old device has been inserted. There is additional tag on Sys-Device-Tag class. Easy to remove in edit Device but hard to remember to upload corrected symbol back to workgroup library.

 

-Arto

Link to comment
  • Vectorworks, Inc Employee
18 hours ago, irenao said:

Hi @Conrad Preen,

I have attached an example file. This is an 2019 file, opened in 2021 and saved.

Even though the lines are defined as rounded they are pictured as a combination of rounded and polyline.

Is there a way to fix this without creating the connections from the scratch?

Thank You

Irena

example.vwx 54.54 MB · 0 downloads

 

Hello @irenao,

 

The 2018 file would be useful so that I can see what went wrong in the update. In the meantime, here is a file with a script that, when executed in the layer with the circuits, fixes their graphics.

 

Best Regards,

Nikolay Zhelyazkov

FixCircuitPathScript.vwx

Link to comment
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...