Jump to content
  • 0

Front View Hotkey Not Working


Dendecko

Question

Hello,

 

I just recently acquired vwx 2021 and have been exploring connectcad and have found that on my number pad the #2 key does not give me a front view.  I would like it to do this especially since the remaining numbers still give me other views (1,3,7,9 isometric, 4 and 6 give side views, 8 gives back view, 5 gives top view). Any ideas of how I could troubleshoot this so I don't keep flipping on the line tool and instead get my front view?

 

Thanks

Link to comment

12 answers to this question

Recommended Posts

  • 0

As far as I know there is no way to force VW to not use the number pad for the views.

 

It is likely that you have some other program that is running and grabbing that keystroke.

 

I am assuming this is on the Mac side? Does the number pad work correctly in other apps (word processor or spreadsheet) to generate the "2" character? Could it be a bad keyboard?

 

Try starting up in safe mode (shut down, wait 10 seconds, hit the power button, immediately hold down the shift key, keep shift pressed until you see the login window) so that nothing else loads and see if that solves the problem.

Link to comment
  • 0
Posted (edited)

Current programs running are just Google Chrome and Vectorworks. 

 

This is a mac with a secondary keyboard.  It does work in other programs and it works in vwx just functions as the 2 from above the keyboard rather than the numberpad so it selects the line tool each time.   

 

I don't know on the bad keyboard since everything else is working chipper but I'll try and test another one.  

 

All else fails I will test safe mode reset.

 

Still open to ideas if anyone has any thoughts.

Edited by Dendecko
typo
Link to comment
  • 0
6 hours ago, Dendecko said:

2 from above the keyboard rather than the numberpad

VW treats the keyboard keys as distinct from the number pad.  I seem to remember that it matters which one you assign in the Workspace Editor.  

Link to comment
  • 0
On 7/7/2021 at 9:45 PM, E|FA said:

VW treats the keyboard keys as distinct from the number pad.  I seem to remember that it matters which one you assign in the Workspace Editor.  

I went into the workspace editor.  Could only input with a command prompt, which should function as a workaround in the short term but I couldn't set a standard view, as far as I know, as an individual keystroke. I'll keep looking around but thanks again as that is at least something to start with.

 

Link to comment
  • 0

The functions of the numeric keypad are not changeable in the Workspace Editor. They are baked very deeply into the VW code.

 

What you did was assign cmd-2 to the Front menu command.

 

There is still something else involved in your setup that is interfering.

 

Is this on your Mac or Windows machine?

Link to comment
  • 0

On a Mac it is relatively simple to create a new user account. I recommend you try that and see if it is VW or something else on your system.

 

Go to System Preferences:Users & Groups. Click the Padlock icon at the bottom and enter your password to unlock the control (if necessary). Click the + button under Login Options to create a new account.  Enter user name and password.

 

Log into the new account and try Vectorworks.  If the keypad shortcuts work, then it is likely something outside of VW that is causing the problem.

 

Log back into your primary account and let us know what happened.

Link to comment
  • 0

@Pat Stanford ok so I figured a little bit out.  This only occurs while I'm in the connect cad workspace, I tested different users and it still happened so I'm wondering if maybe it is an issue with connect cad workspace in 2021?  not entirely sure cause I am pretty shallow when it comes down knowledge on all of this but I successfully checked on two devices, different users and the only through line is that it works fine in every other workspace except for connectcad.

Link to comment
  • 0

Great Catch!!!

 

Yes, I see the same on the ConnectCAD workspace.

 

I was able to fix mine by doing the following.

 

Make the ConnnectCAD workspace active.

Edit the Current Workspace.

Go to Tools:Basic:View/Draw

Select the Line Tool (which has a shortcut of 2 assigned)

Click into the field with the 2 and delete it (make the line tool have no shortcut.

Click the OK button to save the changes to the workspace.

 

Repeat the above, but this time ADD the 2 to the Line Tool making sure to use the number 2 across the top of the keyboard and not the one on the keypad.

 

HTH.

  • Like 1
Link to comment
  • 0
Posted (edited)

@Pat Stanford Fantastic. That worked.  I didn't realize how much I used the keystroke until the last couple weeks where I've been working in the connectcad workspace for the first time.  FYI I did not have to exit and reenter I was able to just delete the number pad 2 and add the keyboard 2 immediately and it worked. Thank you.

Edited by Dendecko
more info
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...