Jump to content

JB P18 fixture symbol

Recommended Posts

Thanks a lot Mark! 

I found it on GDTF Share. 


However it showes a little strange in vision. 

It is flashing when i move the fixture, just as when you have to surfases right on top of each other in vectorworks. 


So i often times only get the outline of the beam. See attached. 




Did i miss a setting someware? 

I tried to remove the fixtures, and do a new MVR export, and import into vision. 


Best from Mathias 



Link to comment
  • Vectorworks, Inc Employee

This happens with some GDTF files. Basically what's happening is that the light emitter is behind some part of the geometry. There's a couple of ways to fix it.


The quickest is to, in Vision, select Root in the Scene Graph. Then in the Properties window, in the Globals section, change Render Shadows from True to False. The good, it's quick and easy. The bad, it turns off shadows for all the geometry in the scene.


Another options is again in Vision. Go to Edit>Vision Preferences. Then under the Graphics tab, change Dynamic Shadows from Objects & Fixtures, to Objects. This will turn off shadows for fixtures. Meaning that your geometry will still have shadows, but your fixtures will not. Again, this effects all fixtures, not just the ones you're having issues with.


If you're finished with your design and don't think you'll be updating it too much more, you can also fix the individual fixtures. Click the arrow next to the fixture names to expand the tree in the Scene Graph. In this example I'm using the P18MK2PRHC, and I've expanded unit 103. Select the Beam (Mesh) in the Scene Graph, then in the Properties window, change the Visible option from True to False as shown below.



You can expand and select the beam mesh of multiple fixtures at the same time by holding the Control key on your keyboard. Then changing the visibility. After you've done this for all the effected fixtures remember to save your file.

The beams may not update immediately. So if you change the visibility to false and nothing happens, don't worry. Move the fixtures pan or tilt, which will update the beam, and all should be good.


Last, you can try editing the GDTF file to try to fix it. On windows only you can right click the fixture in the Scene Graph, and select Update Fixture Type, which will open a window to edit the fixture file. Unfortunately, I'm not sure what exactly is causing the issue, so I can't tell you what needs to be done to fix it. But, if you have the time and want to try, GDTF gives you that flexibility.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...