Jump to content

Importing red marionette plug-in symbols problem


Recommended Posts

Hi everyone,

 

I've made a few marionette symbols ( Create Object Node -> Create Plug-In symbol and it appears as a symbol with a red name). Everything works fine if I stay within the same .VWX file. If I want to import the symbol into another file all the connections between marionette nodes will dissapear. The only way to fix this is to redraw every single connection.

 

The same problem exists even with marionette networks wich are not referencing other symbols. This bug makes the marionette tool worthless when you're working with library .VWX files.

 

Does anyone know of a workaround, or is this a known issue?

 

Thanks in advance.

Link to comment

Hi @JeroenSnoeijen and welcome to the forum,

 

the issue is not the scale to which design layer of the document is set from where you import the symbol, but the scale of the design layer in which the red symbol was originally created (1) compared to the scale of the design layer in which you want to drop the red symbol (2).

Currently if (1) and (2) have different scales all wires within the wrapper of the marionette object will disconnect. If both have the same scale, it will work.

Since you are dropping the symbol into a design layer with the scale 1:50, I will assume that the red symbol was created with a different scale.

If you don't know the scale and don't want to try out different scales, you can always edit the red symbol within the resource manager to get the working wrapper and create a new red symbol. Or if you know the scale, but want to keep the scale of the design layer, a work around would be to change the scale before dropping the red symbol and then changing it back.

 

Regards,

Antonio

  • Like 1
Link to comment
Posted (edited)

Hi Antonio, thanks for your reply!
I've recreated my marionette network in a blank document on a design layer with the scale 1:50. I made it into a plug-in object symbol. Opened another blank document with a design layer of the same scaling and I got the same result as I described in my previous posts. 
 

The marionette network I made and tested in the first file, does not seem to work in the second file.

 

When I try to edit the marionette network in the file I imported the symbol into all connection lines apear as normal. When I move one node, all nodes get disconnected.

 

So I've tried everything from scratch with the same scaling and got the same issue.

Edited by JeroenSnoeijen
  • Like 1
Link to comment

I'm not seeing an issue when dropping the red symbol into the design layer with the 1:50 scale on my end.

 

Please make sure you have the latest ServicePack installed. Try repairing the installation using the VectorworksUpdater. And if that doesn't help with the issue, try setting back your user folder to defaults.

Link to comment

I got the same result on 2 different machines with the latest Vector works servicepacks. 

 

Dropping it on the design layer of the same file works fine. But importing it on another document and dropping in into a design layer of that document with the same scaling causes all nodes to disconnect.

Link to comment

I just tested the file that @JeroenSnoeijen  attached and had the exact same results he did, the Marionette network initially appears to be connected, but anything causing a node to reset resulted in all of the wires disappearing.  I tested this in Vectorworks 2021 SP3.1 (Build 588748) on Windows 10.

 

I was able to get the red symbol to import without breaking by duplicating it, but only if I made the duplicate before importing the other components.  If I imported the original red symbol first, then created the duplicate in the original file and imported the duplicate, the wires would be broken.  Video attached showing how I was able to get it to work.  In any case, there is definitely a bug here.

 

Apologize for the sluggish video, my laptop does not have a great time recording to OBS at the same time as running Vectorworks.

Link to comment

@JeroenSnoeijen and @Jesse Cogswell,

in the meantime I've tested this on a Windows machine as well and I'm having no issues there either. So, it's not a Windows vs. Mac kind of situation.

 

Please try the following:

1) find the user folder (on Windows usually in %AppData%\Nemetschek\Vectorworks)

2) close Vectorworks

3) rename the user folder from "2021" to "2021_"

4) start Vectorworks

5) import the red symbols into a new blank file (design layer scale 1:50) and try to drop them into the design layer

If this fixes the issue on your side, please zip the renamed folder and send me a download link via message, so I can report this with a user folder that makes this bug reproducible.

 

 

Link to comment

I think i found the reason why @Antonio Landberger got it working and I couldn't. Everytime I try to import the marionette symbol I imported the referenced symbols first. When I don't do this, everything works fine.

If you want to reproduce the bug I'm experiencing. First import Scaff large silver part + Scaff small silver part + Scaff small black part. Import the marionette symbol afterwards.

 

Thanks Antonio and Jesse for diving into this issue!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...