Jump to content
  • 0

Can't select objects



All of a sudden, I can't select objects not in the active class. I have 'Show / Snap / Modify Others' turned on. This seems to be only in the one file I am working on. I opened another file and I can select everything as normal. Any suggestions on how to fix this?

Link to comment

6 answers to this question

Recommended Posts

  • 0
Posted (edited)

Tried restarting VW. Didn't help. Restarted computer. Didn't work. All layers turned on. All classes turned on.

Went back two backups and the file works as normal. I didn't notice the problem as all the work I was doing was in the same class.

Another hour lost to the vagaries of VW. Irritating!


Edited by KrisM
Link to comment
  • 0

That's funny because I had the same thing earlier today for the first time. A file where all of a sudden I could only force select objects. Like you, nothing to do with class/layer options, and closing/reopening file + closing/restarting VW had no effect. I ended up abandoning the file + carrying on from a back-up copy... I have a feeling it was something to do with something I did on a sheet layer. Initially it was objects on a sheet layer I couldn't select any more but I managed to rectify that (can't remember how) but nothing would resolve things on the design layer so I jumped ship...

Link to comment
  • 0

I went back to the last working backup. I copy and pasted from the bad file the objects I needed and this is working so far. I had to do objects in three classes but it wasn't too bad. You should never be too complacent with VW. Whenever you're smoothly sailing along, some random weird bug will surface. I just work on single family houses. I cannot imagine the issues using VW on a large project.

Link to comment
  • 0

I am not sure if that was the case here in any way ....

But it could still be that you have "Show / Snap / Modify Others" activated

for Classes - but different setting for Layers - and the elements are not on

active Layer - that it would make sense that you can't edit such objects.


Still after lots of VW years, when anything is not selectable or editable in VW,

I learned that 90% of times it is just a wrong Visibility/Edibility Setting in

Layers+Classes. I still make such mistakes with wrong Class/Layer settings,

every now and then.

So maybe worth to double check.


That does only mean that I carefully check each time my Class/Layer Settings first.

This does not mean that the other 10% would not give enough other reasons

for such issues to happen.

As I also experience some strangeness in Selections or Snapping in latest VW 2021.

If Click Select will not work, Marquee Selection mostly does better.

Snapping from within Extrude Edit Mode was always an adventure.


  • Like 1
Link to comment
  • 0

Ha. Thanks for that. I have always paid attention to the Layer Options - Show etc. I have never looked at the Class Options and didn't realize those options were there. I set the Class Options to "Show / Snap / Modify Others". All are selectable now. Funny thing is that, not knowing this option was available, I have never changed it. VW sometimes changes things without prompting. Another obstacle solved. Slowly acquiring enough solutions to be somewhat functional.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...