Jump to content

Alpha Textures Not Working in Vision 2021

Recommended Posts

Good morning, it's me again.  I've just noticed that my alpha textures are no longer working in SP3.1.  I don't know exactly when they stopped.  I opened up the Vision 2021 Demo file to make sure that something wasn't wrong on my end, and sure enough, the alpha textures didn't work there either.


Screenshot below.  Is this something wrong with my machine?  If this appears to be working on your end, I'll try repairing/reinstalling Vision 2021 and see if that fixes it.



Link to comment
  • Vectorworks, Inc Employee

Hey Jesse,

In the properties window, uncheck the "Use Alpha Channel" box. I'm not sure if it's intended to be that way or not. Either way, setting use alpha to false makes it look correct for me.

Let me know how things work out for you.


Link to comment

Quite right, that did the trick.  It might be a good thing to add to the Help documentation for either the Vision Preferences or Material Properties, or both.  And it would probably be a good idea to reverse the Use Alpha Channel property so that True allows the alpha channel to be used rather than False as it does now.

  • Like 1
Link to comment
  • Vectorworks, Inc Employee

It is a little confusing... when Use Alpha Channel is not checked, then Vision will use the Alpha Texture (if one is present). If Use Alpha Channel is checked, then Vision will use the A from the RGBA image (ie; the alpha channel) instead. This was mainly a hold over from older versions of Vision which did not support using the A from the RGBA image; in older versions the only option was Alpha Texture.


This post has brought up some interesting topics and talking points, though! I think I can bring some of these ideas to my next meeting. Thanks again for your feedback @Jesse Cogswell 🙂 

Link to comment
  • Vectorworks, Inc Employee
3 minutes ago, Jesse Cogswell said:

VW does not allow for alpha textures without using the transparency shader

I may be wrong, but at a quick glance this does seem to be the case. In order to get an alpha mask in VW, I believe the transparency shader must be used. I just didn't see any options for the primary image that allowed for masking with the alpha channel.


FWIW, the main reason this was originally added was for NDI Streams actually 😛  A customer was in a situation where they had to separate their single RGBA stream into an RGB stream and a separate stream for the alpha. When adding this new feature, not only was this easier for them to use a single RGBA stream but performance in Vision was better as well as we were not handling as many NDI input streams. It kind of "just so happened" that this also worked with the alpha channel from the image assigned to Texture 😂

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...