Jump to content
  • 0
hollister design Studio

Site Model - 2d Contour Labels - more control please.

Question

Two things.

 

1. Please put 'show contour labels' on the OIP.

 

2. Please allow visibility control by class.

 

Notes:

I want Contour Labels to be visible is some viewports and not in other .

  • I went to Site Model Settings/Graphic properties/2D contour Labels.
  • I created a new class called 'Site-2D contour Labels.
  • I  checked 'show contour labels'.

Turning 'Site-2D contour Labels' class on and off in a design layer has no effect on visibility.

Turning 'site-2D contour labels' on or off or grey in my classes menu for viewports has no effect on visability

 

Share this post


Link to post

3 answers to this question

Recommended Posts

  • 0

Hey @hollister design Studio,

I just did the same test and it works on my end. Did you set the class to "use at creation" and in the site model settings all attributes are "set by class"?

Here is  a sample fileSite Model-contours off.vwx

Turn the visibility of class "contour labels" off.

Let me know if you get it working.

Best,

Tony

Share this post


Link to post
  • 0
4 hours ago, Tony Kostreski said:

...and in the site model settings all attributes are "set by class"...

 

Thanks Tony - that was it!

 

Really buried down in there isn't it...

 

Label visibility is a basic feature of a contour map and should be a very quick on/off while working.

Setting up a class for labels is great (and I'm so thankful for you showing me how) but if that's going to be 'best practice' than I shouldn't have to dig so deep to enable it.

It should be right in the site model  "2d display" settings tab - along with the setting for major or major and minor contours.

 

And I would still like to see it in the OIP!

 

 

 

 

  • Like 1

Share this post


Link to post
  • 0
1 hour ago, hollister design Studio said:

Label visibility is a basic feature of a contour map and should be a very quick on/off while working.

Setting up a class for labels is great (and I'm so thankful for you showing me how) but if that's going to be 'best practice' than I shouldn't have to dig so deep to enable it.

It should be right in the site model  "2d display" settings tab - along with the setting for major or major and minor contours.

 

And I would still like to see it in the OIP!

I agree it should be easier to get to this point. Make sure to "Save Site Model Settings" so you're really only setting up how Site Models are created once. You can save this to your template so that it automatically creates those classes. You can even save multiple different Site Model settings depending on what's required for the project.

 

I think adding a button to the OIP is a nice wish — I'll submit a Vectorworks Enhancement.

 

 

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...