Jump to content

Worksheet copy-paste and Hoist reports problems


AStein

Recommended Posts

Hey guys

I'm trying to make a layout datum in excel (basically X/Y columns in feet and whole inches) which used to be a very simple affair. Hoist report --> copy paste to excel and bob's your uncle.

 

Now it looks like the hoist report function has been deleted in 2021?! OK, so I created a report for objects with a hoist record and that worked. But now when I copy paste to excel it pastes, not in feet and inches, but as a decimal string. It's displaying correctly in worksheets, but copy-pastes as a decimal in excel and google sheets. Very frustrating. 

 

Bonus topic: Am I missing something with the 2021 hoist stuff in general? It seems worse. More steps, less options, It lags my very fast system, which never happened with hoist in 2020 and there's some OIP stuff missing that I used to use. What's going on here?

Link to comment

I don't have a good workaround for you.

 

I believe that in VW2020, the data from the hoist object was a string while in VW2021 the value is being returned as a number. VW knows how to display that number as Feet & Inches but when you transfer it to Excel, Excel does not.

 

It looks like there is a formatted text version of the origin fields. Try using these instead of the formulas you are currently using.

 

'BrxHoist'.'OriginX_formated'

'BrxHoist'.'OriginY_formated'

 

HTH.

Link to comment

Thanks Pat. I couldn't get that to work the way I wanted, but I did find a workaround that might be a little more friendly to people like me (Knuckle-dragging riggers). I'll detail it here in case someone else runs into this issue. Also I appreciate your time. I see you solving problems all over this forum!

 

Make a backup file in case you're polluting other departments with our whole inch "precision"

 

First:

File --> Document Settings --> Units

"Decimal Precision" Dropdown menu: select "1"

Hit "OK"

 

Next:

Spotlight --> Reports --> Create report

Objects with Hoist record

Add: "Origin X(formatted)" and "Origin Y(formatted)"

Click on one of your adds and then click "Format Field"

"Number Format" dropdown menu: Select "Text"

Do this for both adds

 

Now you can copy-paste into excel

 

It's a pretty quick fix but damn...

Link to comment
  • Vectorworks, Inc Employee

@AStein Have you tried the new export excel worksheet option instead of copy and pasting?

the Export Worksheet command is in the worksheets file menu, it will export your worksheet without you needing to change the fields format to text.

Link to comment
  • 1 month later...

@jcogdell I have, thank you. Formatting the VW sheet as a text string rather than an actual number seems to be the ticket.

 

I really hope VW is talking to someone about the new hoist tool. Most people in my circle have abandoned it and installed the legacy hoist tool as a workaround. 

  • Like 1
Link to comment
  • 2 months later...
On 5/11/2021 at 8:25 AM, AStein said:

I really hope VW is talking to someone about the new hoist tool. Most people in my circle have abandoned it and installed the legacy hoist tool as a workaround. 

 

Finally getting back to Vectorworks after a pandemic hiatus, and I fully agree with this statement.   Really shouldn't have to write or modify VectorSctpts to restore what was a well functioning tool.  

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...