Jump to content
joesnikon

Vectorworks Locking Up

Recommended Posts

I'm using Vectorworks for Mac and learning my way through using Marionette.  I got into this odd situation where the file that I was using to create and practice my script development keeps locking up Vectorworks. I've tried resetting both Vectorworks and my Mac, but no luck. The lock up occurs specifically when I try to select the black rectangle in the middle of the page - it was created using a very simple script. I'm hoping to be able to get back into this file, as it has a couple of symbols that I spent a fair amount of time creating. Thank you.

Symbols.vwx

Share this post


Link to post

As a follow up to my last question - The rectangle node stopped working. I can create every other type of object, no problem, but the rectangle tool produces no results. When I enter debug mode, the inputs display the correct values but the output of the node remains emptyrectangle.vwx (0). This loss of functionality occurred at the same time as my previous problem/question.

Screen Shot 2021-03-14 at 8.23.21 PM.png

Share this post


Link to post

Pure guess, but could it be that Rectangle are 2D objects and you are passing a Point3 as the insertion point?

Share this post


Link to post

Nope, tired that 2d input point too... nothing. I've been using the rectangle node regularly, without issues, over the past week as I've been learning my way around Marionette. This seems to coincide with the locking up of one of my files. I've tried restarting both Vectorworks and my Mac but haven't had any luck. Every other object node works exactly as expected - but not the rectangle node.

Share this post


Link to post

Last week I had the same problem with a 2d / 3d symbol, that I wanted to rotate with Marionette.
2d "planview" you can apparently only rotate it with a 2d vector angle.

Same with your rectangle.

 

837699617_Bildschirmfoto2021-03-15um11_41_16.thumb.png.bebf93d6631b0d8e83119b77db36e4c2.png

  • Like 1

Share this post


Link to post

better you take the "enhanced Rectangle Node"... from DomC 🙂

 

 

Share this post


Link to post

Hi Pat - I did try to copy the script into a new document. I even created a new document and started the script from scratch. Neither one of these options worked. Interestingly enough, every other rectangle related node works fine, including creating a rectangle with 2 points.

 

M.graf, I'll try the enhanced rectangle tool from DomC. Thank you.

Share this post


Link to post

You might want to consider uninstalling and reinstalling VW.  If the Rectangle Node is corrupted there could be others as well.

Share this post


Link to post
On 3/15/2021 at 1:35 AM, joesnikon said:

but the rectangle tool produces no results

Hi
The Rotation Vector is the issue. Just disconnect or 0,0,0 Vector and it will draw the rectangle

Share this post


Link to post

@DomC Thanks for the tip. Zeroing out the vector input didn't work, but disconnecting it did. Part of my problem (and I have many) in learning how to use the various nodes, is that not every node's description makes it obvious as to what's expected. Sometimes it's just trial an error for me. The good news is that your rectangle tool worked exactly as expected.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...