Jump to content

Vectorworks Locking Up


Recommended Posts

I'm using Vectorworks for Mac and learning my way through using Marionette.  I got into this odd situation where the file that I was using to create and practice my script development keeps locking up Vectorworks. I've tried resetting both Vectorworks and my Mac, but no luck. The lock up occurs specifically when I try to select the black rectangle in the middle of the page - it was created using a very simple script. I'm hoping to be able to get back into this file, as it has a couple of symbols that I spent a fair amount of time creating. Thank you.

Symbols.vwx

Link to comment

As a follow up to my last question - The rectangle node stopped working. I can create every other type of object, no problem, but the rectangle tool produces no results. When I enter debug mode, the inputs display the correct values but the output of the node remains emptyrectangle.vwx (0). This loss of functionality occurred at the same time as my previous problem/question.

Screen Shot 2021-03-14 at 8.23.21 PM.png

Link to comment

Nope, tired that 2d input point too... nothing. I've been using the rectangle node regularly, without issues, over the past week as I've been learning my way around Marionette. This seems to coincide with the locking up of one of my files. I've tried restarting both Vectorworks and my Mac but haven't had any luck. Every other object node works exactly as expected - but not the rectangle node.

Link to comment

Hi Pat - I did try to copy the script into a new document. I even created a new document and started the script from scratch. Neither one of these options worked. Interestingly enough, every other rectangle related node works fine, including creating a rectangle with 2 points.

 

M.graf, I'll try the enhanced rectangle tool from DomC. Thank you.

Link to comment

@DomC Thanks for the tip. Zeroing out the vector input didn't work, but disconnecting it did. Part of my problem (and I have many) in learning how to use the various nodes, is that not every node's description makes it obvious as to what's expected. Sometimes it's just trial an error for me. The good news is that your rectangle tool worked exactly as expected.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...