Jump to content
Developer Wiki and Function Reference Links ×

from PIP install Image


Recommended Posts

This is the latest Pillow library for Python 3.8 (which is the Python version shipped with Vectorworks 2021):


    if platform == 2:
        PIL = 'https://files.pythonhosted.org/packages/fc/2f/b0948c5aef8bdb6954b8421177c883818e6ae901a8da7c83fea9e7bd6d10/Pillow-8.1.2-cp38-cp38-win_amd64.whl'
        PIL = 'https://files.pythonhosted.org/packages/b9/43/a53278d0dc94b9c3e6db43bba873a240c3339a762ac05df197b8eaca819f/Pillow-8.1.2-cp38-cp38-macosx_10_10_x86_64.whl'

It can be found here:

Pillow 8.1.2



Link to comment
  • 2 months later...

Hello there, I'm struggling a little bit here. I want to use a marionette halftone script and it does show me a error message regarding PIL.

I guess this is because of Python Pillow?

I tried to use your installer network and still can't manage to install it. I attached a screenshot with the corresponding error message.





Any ideas how to fix this?


(I hope I'm on the right train here, since I am not really sure this is the problem...)





Link to comment

hello bgf,

i only test it with OSX.

Please check this Link for Window's


greatings M.Graf 

Link to comment

Thanks for the quick answer! 

I'm still getting the same error message. Maybe it is some other issue... I may try to reinstall VW. 

Thanks again! 


Edit: Reinstalling did not fix it either...

Edited by bgf.s
Link to comment
  • 1 month later...
  • 1 year later...

I also have this issue on a MacBook Pro with an Apple M1 Pro chip. macOS 13.2.1. Vectorworks 2023 SP3 (Build 684728).




I installed using the Install Python Library feature of the Marionette Tool preferences. This is the URL for Pillow that I put in:




I also tried deleting the PIL directory shown in the error code above and installing some different versions from https://pypi.org/project/Pillow, but they didn't work either. Is there a proper way to uninstall a Python library from Vectorworks? Searching around the internet suggests that many times this error is resolved by updating to the latest version or re-installing Pillow, but these reference points aren't within the context of Vectorworks.

Edited by Anthony Esau
Link to comment
  • 2 weeks later...

Thank you for sharing SimA. I had to modify the command to "pip3 install Pillow" for it to run on my machine. And the results are listed below.


username@users-mbp ~ % pip3 install Pillow
Defaulting to user installation because normal site-packages is not writeable
Collecting Pillow
  Downloading Pillow-9.4.0-cp39-cp39-macosx_11_0_arm64.whl (3.0 MB)
     |████████████████████████████████| 3.0 MB 1.7 MB/s
Installing collected packages: Pillow
Successfully installed Pillow-9.4.0
WARNING: You are using pip version 21.2.4; however, version 23.0.1 is available.
You should consider upgrading via the '/Applications/Xcode.app/Contents/Developer/usr/bin/python3 -m pip install --upgrade pip' command.


However, Pillow still would not run in Vectorworks, even with some additional mucking around updating Pip and installing different versions of Python with Homebrew. (I had uninstalled several versions of Python previously for an unrelated reason and thought installing the latest version might help this situation.)


BUT what did work was once again using the Install Python Library feature of the Marionette Tool preferences with the link to the "Pillow-9.4.0-cp39-cp39-macosx_11_0_arm64.whl" file listed in the output above from https://pypi.org/project/Pillow. This file was different than the one I had installed previously. And now Pillow runs in Vectorworks! I believe this is the one thing that made it work rather than any of the other changes with Pip and Python.


Thanks for sending me in the right direction SimA!



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...